forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin <forr...@kegcl.demon.co.uk>
Subject Problems using old views.
Date Thu, 13 Oct 2005 17:10:36 GMT
I've done a fresh svn checkout after having problems with svn up.
Now at #314981.

cd main
build.sh clean; build.sh

cd ../etc
(noticed views-old.sh refers to old view plugins)
views-old.sh

cd /my/work
forrest seed-basic

(noticed forrest.properties: project.required.plugins refers to)
org.apache.forrest.plugin.input.viewHelper.xhtml.ls
org.apache.forrest.plugin.output.themes,
org.apache.forrest.plugin.internal.structurer

(changed to use)
org.apache.forrest.plugin.input.viewHelper.xhtml.ls
org.apache.forrest.plugin.output.viewHelper.xhtml,
org.apache.forrest.plugin.internal.view

(still the same org.apache.forrest.plugin.input.viewHelper.xhtml.ls?)

forrest site

(gives error)

X [0]                                     linkmap.html
BROKEN: /usr/java/forrest/build/plugins/org.apache.forrest.plugin.internal.structurer/resources/views/default.fv
(No such file or directory)
Total time: 0 minutes 10 seconds,  Site size: 0 Site pages: 0

I can't see if I've done something wrong to reference structurer?

Looks like maybe something in core uses structurer? Could someone
help with the revision #? to go back to a working version. Thanks.
It hurt last time I did it. Iterative trial and error on dial up :(

Do I need to stay at the core rollback revision #? and just 'svn up'
for old view plugins? 

I know old views aren't really supported so no need for a jira. I
just hope I can get back to an old working version in core and old
view plugins. Thanks.

Kevin



Mime
View raw message