forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Batlin" <a...@batlin.com>
Subject RE: [Pipeline Question ?]
Date Tue, 27 Sep 2005 06:59:23 GMT
Ross,

I was excited to see the addition of xconf capability into plugins. See
http://svn.apache.org/viewcvs?rev=227190&view=rev.

I rebuild cocoon with authentication and session blocks, and added the jars
to 'plugin/lib' and the xconf files from the
'cocoon-2.2.0-dev\build\webapp\WEB-INF\xconf' to 'plugin/conf'.

This error message was returned:

BUILD FAILED
D:\apps\forrest-0.8\plugins\build.xml:339: The following error occurred
while executing this line:
D:\apps\forrest-0.8\main\targets\plugins.xml:348: The following error
occurred while executing this line:
D:\apps\forrest-0.8\main\targets\plugins.xml:370: The following error
occurred while executing this line:
D:\apps\forrest-0.8\main\targets\plugins.xml:390: Not a valid xpatch file:
D:\apps\forrest-0.8\build\plugins\com.batlin.forrest.plugin.internal.profile
d\conf\cocoon-authentication-fw.xconf

So am bit confused, on two counts:
1. if xpatch is required, how do I generate this file?
2. why are we using xpatch, when the current cocoon.xconf uses includes,
can't we do the same here?

Many thanks,


Alex.



Mime
View raw message