forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antonio Gallardo <agalla...@agssa.net>
Subject Re: current forrest trunk seems to be broken
Date Wed, 21 Sep 2005 16:27:11 GMT
Hi:

I run forrest and cocoon on FC4 since june 2005. I don't have any error. 
Please see:

http://wiki.apache.org/cocoon/Installing

Best Regards,

Antonio Gallardo.

Mark Eggers wrote:

>I just tried this on Fedora Core 4.  I get exactly the
>same error.
>
>I had two ideas when you mentioned a potential issue
>with the classpath.  The first idea was that since Sun
>insists on putting Java in "Program Files" for
>Windows, the space was somehow creating problems.
>
>The second idea is that I have my own installation of
>ant (with ANT_HOME set and ANT_HOME/bin in my path).
>
>Here are the steps I took to reproduce this on Fedora
>Core 4.
>
>Environment
>===========
>Fedora Core 4 2.6.12-1.1447_FC4
>java 1.5.0_04-b05 in /usr/java linked from
>/usr/jdk1.5.0_04
>no CLASSPATH
>export FORREST_HOME=/home/mdeggers/src/forrest
>export PATH=$PATH:$FORREST_HOME/bin
>
>Case 1
>======
>1. svn update -r 290585
>2. cd $FORREST_HOME/main
>3. ./build.sh clean
>4. ./build.sh
>5. cd $FORREST_HOME/plugins
>6. ./build-all.sh (shell script for building all
>plugins)
>7. cd $FORREST_HOME/whiteboard/plugins
>8. ./build-all.sh (shell script for building all
>plugins)
>9. cd ~mdeggers/src/sites-src/
>10. mkdir new-site
>11. cd new-site
>12. forrest seed
>13. forrest
>
>I then unset ANT_HOME and removed ANT_HOME/bin from my
>path.  I removed ~mdeggers/src/sites-src/new-site and
>did the following:
>
>Case 2
>======
>1. cd $FORREST_HOME/main
>2. ./build.sh clean
>3. ./build.sh
>4. cd $FORREST_HOME/plugins
>5. ./build-all.sh (shell script for building all
>plugins)
>6. cd $FORREST_HOME/whiteboard/plugins
>7. ./build-all.sh (shell script for building all
>plugins)
>8. cd ~mdeggers/src/sites-src/
>9. mkdir new-site
>10. cd new-site
>11. forrest seed
>12. forrest
>
>The same build error occured.
>
>I thought there might also be some issues with Java 5.
>I then tried switching to the following java version:
>
>java 1.4.2_08-b03 from /usr/j2sdk1.4.2_08
>
>I removed the 1.5 version from my PATH, added the
>1.4.2 bin directory to my PATH, and set JAVA_HOME
>appropriately.
>
>I then did the following:
>
>Case 3
>======
>1. cd $FORREST_HOME/main
>2. ./build.sh clean
>3. ./build.sh
>4. cd $FORREST_HOME/plugins
>5. ./build-all.sh (shell script for building all
>plugins)
>6. cd $FORREST_HOME/whiteboard/plugins
>7. ./build-all.sh (shell script for building all
>plugins)
>8. cd ~mdeggers/src/sites-src/
>9. mkdir new-site
>10. cd new-site
>11. forrest seed
>12. forrest
>
>Same error.  This was with ANT_HOME still unset and
>$ANT_HOME/bin removed from my PATH.
>
>I have seen EOL (DOS vs. UNIX) problems cause similar
>issues in make files, but never in a Java environment.
>
>Thoughts on what I might be doing wrong (or different)
>would be greatly appreciated.
>
>/mde/
>
>--- Juan Jose Pablos <cheche@apache.org> wrote:
>
>  
>
>>Mark Eggers wrote:
>>    
>>
>>>This is on Windows/2000 Professional.  I've not
>>>      
>>>
>>tried
>>    
>>
>>>it on Fedora Core 4 yet.
>>>      
>>>
>>It looks a problem with classpath on your system.
>>our forrestbot builds 
>>fine.
>>
>>Cheers,
>>cheche
>>
>>
>>    
>>
>
>
>__________________________________________________
>Do You Yahoo!?
>Tired of spam?  Yahoo! Mail has the best spam protection around 
>http://mail.yahoo.com 
>  
>


Mime
View raw message