forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Eggers <its_toas...@yahoo.com>
Subject Re: current forrest trunk seems to be broken
Date Wed, 21 Sep 2005 17:32:16 GMT
I'll add the --noconfig and see what happens.  I am
using Sun's java instead of GNU's java as supplied by
Fedora.  My PATH is set appropriately to call Sun's
java first.  I've not had any problems until recently.
 I've also seen the same problem on Windows/2000
Professional.

Same error.

I also deleted the entire forrest directory and
checked out the same version:

svn co http://svn.apache.org/repos/asf/forrest/trunk \
-r 290585 forrest

With the same error.

I also noticed the directory:

${plugins.localDeploy-dir}

being created for 

org.apache.forrest.plugin.output.htmlArea

=======================
Ah ha!!!!!! Found it.
=======================

If I build the plugins manually then forrest fails. 
This occurs with either my build script (see
attached), or changing to the plugin directory and
doing:

$FORREST_HOME/tools/ant/bin/ant local-deploy

If I let forrest build the plugins dynamically, then
it works.

Unfortunately, this doesn't currently work for the
views environment.

My Cocoon 2.1.7 environment (with the exception of JSP
pages and one Groovy page) works fine under JDK 1.5 /
Tomcat 5.5.9 on both Windows/2000 Professional and
Fedora.  I suspect a Jasper/Xerces issue for the JSP
pages which can be solved by using Saxon.  I don't
know how to solve the null pointer exception, but at
first glance it appears to be part of the same issue.

/mde/

--- Antonio Gallardo <agallardo@agssa.net> wrote:

> Hi:
> 
> I run forrest and cocoon on FC4 since june 2005. I
> don't have any error. 
> Please see:
> 
> http://wiki.apache.org/cocoon/Installing
> 
> Best Regards,
> 
> Antonio Gallardo.
> 


		
__________________________________ 
Yahoo! Mail - PC Magazine Editors' Choice 2005 
http://mail.yahoo.com
Mime
View raw message