forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Williams <>
Subject locationmap mounting [was: Re: [jira] Commented: (FOR-573) Provide locationmap mounting capability
Date Mon, 29 Aug 2005 19:39:29 GMT
On 8/29/05, Thorsten Scherler (JIRA) <> wrote:
>     [ ]
> Thorsten Scherler commented on FOR-573:
> ---------------------------------------
> I tried to rewrite the internal.view plugin with the locationmap, but that was not working
like I expected. I only have been able to see the lm rewritting when I did forrest run in
the root of the plugin. I reckon it is because of this issue.
> Is there a an example of the mount in the lm?

I'm replying onlist instead of through JIRA to keep JIRA clean of
free-flowing discussion -- assuming that's desired.

I've pasted a mounting example below.  Note that because of another
issue, the lm being mounted *must* exist.  I'm hoping to fix that this
evening though.  Then the syntax will change to become:
  <mount src="somelocationmap.xml"/>

That said, I'm not sure if that's causing your issue or not.  Are you
saying you the locationmap isn't working when you try it on a
seed-sample site?  I actually would have expected it to be the other
way around since plugin-locationmaps have yet to be tested at all and
aren't even being mounted via the workaround AFAIK.

<locationmap xmlns="">

    <matchers default="lm">
  <mount src="{project:content}locationmap2.xml"/>
	   <match pattern="rewriteDemo/**">
	     <location src="{1}.xml" />
	   <match pattern="remoteDemo/**.xml">

View raw message