forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thorsten Scherler <thors...@apache.org>
Subject debugging views - short (was Re: [views] head broken?)
Date Thu, 18 Aug 2005 23:32:57 GMT
Diwaker reported that his views head is broken.

Which views are you using? Homegrown or default?

When I agreed to Ross, I as well agreed to the method chosen:

On Thu, 2005-08-18 at 12:36 +0200, Thorsten Scherler wrote: 
> On Thu, 2005-08-18 at 10:53 +0100, Ross Gardler wrote:
> > > I just did:
> > 
> > SVN up
> > cd main
> > build.sh clean
> > build.sh
> > 
> > and still no problems.
> > 
> 
> Same here.

BTW there are some steps missing (building the plugins!):
cd $FORREST_HOME/etc
sh views.sh

This method means we have tested the default.fv. I tested on another
computer, on the one I am right now is only a patched version of forrest
which I will commit later on. 

I have refactored code for the view resolver on my harddrive and got
weird error messaged last night. First I thought that is my new code,
but now I played around with some views and found out that it is only
happening in one project (that worked perfect before).

Last night I got (for this project):
java.lang.RuntimeException: ElemTemplateElement error: Found more than
one template named: navigation-link-index-content

That should not be possible. ;-)

I checked 
a) http://localhost:8888/getStylesheet.xhtml.index
That worked perfectly without an error. No direct calls to
"navigation-link-index-content" found

b) http://localhost:8888/prepare.include.xhtml.index
Worked as well. I found indeed two times the
"navigation-link-index-content" template. 

Now I was trying to figure out why only this one project had this bug.
The answer was that I modified a default contract in my local project
that now caused this bug.

First general rule of debugging views is make sure your modified
contracts are not causing the problem.

salu2
-- 
thorsten

"Together we stand, divided we fall!" 
Hey you (Pink Floyd)


Mime
View raw message