forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cyriaque Dupoirieux <Cyriaque.Dupoiri...@pcotech.fr>
Subject Re: [<div/> again]
Date Fri, 29 Jul 2005 13:57:17 GMT
Thorsten Scherler a écrit :

>On Fri, 2005-07-29 at 10:25 +0200, Cyriaque Dupoirieux wrote:
>  
>
>>Ok, it works.
>>The only thing is when I edit the XHTML source, I have this :
>>
>><div class="clearboth">Â </div>
>>
>>It seams that &#160; is translated to  ?
>>Why don't you use &#32; ?
>>
>>    
>>
>
>http://www.html-world.de/program/html_sz.php
>
>It is in german, but you will understand. ;-)
>
>Did you try with &#32;? What is the outcome? I will try after work. 
>  
>
It gives this :
   
    <div class="clearboth" /> !

So I prefer &#160; :-P

You know, I don't really understand why browsers are disturbed by empty 
<div/> tags.
But it is a fact, and I have a proof !

Have a look here : 
http://cyriaque.dupoirieux.free.fr/testviews1/testDiv.html

Regards,
Cyriaque,

>salu2
>
>  
>
>>Cordialement,
>>Cyriaque,
>>
>>Thorsten Scherler a écrit :
>>
>>    
>>
>>>On Thu, 2005-07-28 at 18:08 +0200, Cyriaque Dupoirieux wrote:
>>> 
>>>
>>>      
>>>
>>>>Thorsten Scherler a écrit :
>>>>   
>>>>
>>>>        
>>>>
>>>>>>in order to generate <div> </div> if nbsp='true' instead
of <div/> which is not well interpreted by browsers.
>>>>>>But this &#160; is not enough, the generation still gives <div/>...
>>>>>>       
>>>>>>
>>>>>>            
>>>>>>
>>>>>¿?
>>>>>
>>>>>Are you sure? I tried it and is working fine for me.
>>>>>
>>>>>
>>>>>     
>>>>>
>>>>>          
>>>>>
>>>>Actually, I don't understand what happens, if I write a trace to see if 
>>>>it's the good template which is used, the generation is OK because of my 
>>>>trace (the div tag is no more empty...)
>>>>(It's a little bit like Heisenberg uncertainty principle, the observer 
>>>>disturb the result of the experiment :-) )
>>>>
>>>>Let it as it is I will continue my investigations, it may come from 
>>>>something else in my environment...
>>>>
>>>>   
>>>>
>>>>        
>>>>
>>>try a "forrest clean" in your project and build.sh clean in forrest. 
>>>
>>>As well I recommend to "ant clean" all view plugins.
>>>
>>>After a build everything should work fine.
>>>
>>> 
>>>
>>>      
>>>
>>>>>     
>>>>>
>>>>>          
>>>>>
>>>>>>I propose :
>>>>>>	<xsl:if test="@nbsp='true'"><span/></xsl:if>
>>>>>>
>>>>>>  
>>>>>>
>>>>>>       
>>>>>>
>>>>>>            
>>>>>>
>>>>>Hmm, I do not like that much because the <span/> do not belong in
there
>>>>>IMO.
>>>>>
>>>>>
>>>>>     
>>>>>
>>>>>          
>>>>>
>>>>Sure you are right...
>>>>By the way, can you try to add something like this in your *.fv and tell 
>>>>me the result :
>>>>
>>>>       <forrest:hook nbsp="true" class="test"/>
>>>>
>>>>   
>>>>
>>>>        
>>>>
>>><div class="test"> </div>
>>>
>>>HTH
>>>
>>>salu2
>>>thorsten
>>>
>>> 
>>>
>>>      
>>>
>>>>Regard,
>>>>Cyriaque,
>>>>
>>>>   
>>>>
>>>>        
>>>>
>>>>>salu2
>>>>>
>>>>>
>>>>>
>>>>>     
>>>>>
>>>>>          
>>>>>
>>>>>>PS: Sorry, I have lost the thread...
>>>>>>
>>>>>>  
>>>>>>
>>>>>>       
>>>>>>
>>>>>>            
>>>>>>

Mime
View raw message