forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antonio Gallardo" <agalla...@agssa.net>
Subject Re: Questions about the release instructions
Date Sat, 11 Jun 2005 12:12:11 GMT
On Jue, 9 de Junio de 2005, 11:10, Ross Gardler dijo:
> David Crossley wrote:
>> Ferdinand Soethe wrote:
>>
>>>Any comments on this proposal?
>>
>>
>> Yes i sent comments under another thread name:
>> "required Java version"
>> Would someone please follow up. It is a very important point.
>
> I've switched on my "lazy consensus" mode for this issue. In other words
> I agree with Davids suggestion in the other thread (I think it was to
> test against 1.4.1 and update docs accordingly).

The minor version number (after 1.4) is not much important for defining
software requirements (minor version number always means full backward
compatibility).

As a sample, look at cocoon, we claim to be java 1.3 or higher. For
testing compatibility, given the above facts in the real world we only
need to use currently 3 JDK's

1.3
1.4
1.5

Now if I use to check for 1.3, said:

1.3.1_14, 1.3.1_15 or 1.3.0_3 is irrelevant. It will run.

The same apply for the other 2 java versions.

I will suggest to state only "1.4" as the minimal JDK version in forrest?

Best Regards,

Antonio Gallardo.


Mime
View raw message