forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ross Gardler <>
Subject Re: [Testing 0.7rc1] Calling site from ant may not download plugin
Date Fri, 17 Jun 2005 09:54:47 GMT
Ron Blaschke wrote:
> Ross: simplifiedDocbook worked ok, the page rendered nicely.  Thanks!
> There are two other things I'd like to mention
> 0.7/docs/your-project.html says
>     <property environment="env"/>
>     <property name="forrest.home" value="${env.FORREST_HOME}"/>
>     <import file="${env.FORREST_HOME}/"/>
> but is in directory main, so I guess it should read
>     <import file="${env.FORREST_HOME}/main/"/>

Correct - fixed - thanks.

> Another problem seems to be fetching the plugin, when calling
> from within ant.
> ...
> check-java-version:
> This is apache-forrest-0.7-dev
> Using Java 1.4 from C:\Program Files\Java\jdk1.4.2\jre
> ...
> check-plugin:
> org.apache.forrest.plugin.input.projectInfo is not available in the build dir
> =====
> Unable to retrieve the ${} plugin.
> ...
> Two noteworthy things: Calling "forrest init-plugins" installs the
> plugin sucessfully.  And the error message says "${}",
> instead of the real name of the plugin.

The two things are related. It looks like that the {} is not 
being set for some reason (and I guess {} is not set either.

These are set in the init-plugins target of targets/plugins.xml

I have no idea why this is happening and don't have the time to explore 
this just yet. I can't raise an issue either since the issue tracker is 
down right now.

If we don't get time to fix this before the release I suggest adding a 
warning to the your-project.html in the instructions for using Forrest 
via Ant (i.e. you must manually install the plugins for it to work).

Thanks for spotting this one.


View raw message