forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: release plan for 0.7
Date Thu, 23 Jun 2005 16:59:05 GMT
David Crossley wrote:
> Ross Gardler wrote:
> > David Crossley wrote:
> > >We are getting close now. Following the svn commits and the
> > >etc/RELEASE_PROCESS.txt you see what i have been doing today.
> > >
> > >We are up to the stage of waiting for the mirrors to update.
> > >
> > >Would someone else please send the announcement. However,
> > >you need to wait until the website is updated and the
> > >distribution mirrors are ready.
> > 
> > > See etc/announce.txt for a template to get you started.
> > 
> > It will not be me, I'm about to leave the office for the day. Can 
> > someone else in Europe please step up to do this.
> 
> Glad that no-one did, because our download page is broken.
> At least for me. It stops with an empty Options list.

I found the problem. The generated mirror.html page was missing the
crucial xml comments which are parsed by the mirrors.cgi script.
It seems to be a recent change in behaviour. The old "ihtml"
facility passed the xml comments through from the source html.

I updated that by hand. So the new mirrors.html should get
rsync live in about fifteen minutes.

> > >The mirrors part is easy, just watch http://www.apache.org/mirrors/
> > >and decide when is a fair tradeoff. The main eu.apache.org mirror
> > >received it at UTC 02:00 (so 6.5 hours ago).
> > >
> > >The website part was tricky, but should now automatically happen.
> > >It is rsynced from people.apache.org every two hours. After the
> > >last run i did ssh people.apache.org and removed everything,
> > >then did a new 'svn co' of forrest/site repository. So on the
> > >next run we should have our shiny new website. That should be
> > >around one hour away.
> > 
> > Removed *everything*. Does that mean the plugin docs as well? These are 
> > deployed separately.
> 
> I thought that they got 'svn commit' to the forrest/site repository
> which got replicated on the server. Not all plugin docs were deployed
> to their new location before i started and it looks like the same set now.

Okay that works as i thought. I just tested by deploying the docs for
the PDF plugin. The rest need to be deployed.
cd forrest/trunk/plugins
cd org.apache.....
$FORREST_HOME/tools/ant/bin/ant deploy-docs
See the notes in howto-buildPlugin.html

So far we have ...
org.apache.forrest.plugin.input.OpenOffice.org
org.apache.forrest.plugin.input.PhotoGallery
org.apache.forrest.plugin.input.listLocations
org.apache.forrest.plugin.input.simplifiedDocbook
org.apache.forrest.plugin.output.pdf

-David

Mime
View raw message