forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: testing rc3
Date Wed, 22 Jun 2005 06:06:41 GMT
David Crossley wrote:
> I tested rc3 on Mac OS X. Java 1.4.2_05
> 
> The usual things worked well and i also did the DocBook/XSL test
> and the "Download DTD" example. I have not yet tried the forrestbot.
> 
> However i had some trouble with deploying a webapp under a full Jetty.
> 
> The default seed site my-project.war was okay, but the war from
> site-author was broken with a Cocoon error ...
> request-uri: /forrest/index.html
> cause:
> /private/tmp/Jetty__36366__forrest/webapp/project/skinconf.xml (No such file or directory)
> 
> I wonder if some configuration is not being handled, because
> our skinconf.xml is at a non-standard location.

FOR-551 non-standard "project.content-dir=." does not get packed with WAR archive

> Another issue: The core DTDs are fine, but additional DTDs are not
> being handled via a webapp, e.g. the "Download DTD" example or
> DTDs from plugins.

That is three separate issues and each has a workaround or a solution ...

FOR-548 project DTD catalogs are not included when running as a servlet WAR

FOR-549 plugin DTD catalogs are not included when running as a servlet WAR"

FOR-550 build/plugins/catalog.xcat has full pathnames to each individual
plugin catalog.xcat

-David

Mime
View raw message