forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: [testing 0.7rc1] First test
Date Tue, 14 Jun 2005 23:21:19 GMT
Nico Veenkamp wrote:
> Hi,
> 
> I did a quick test of the 0.7rc1. Please find my findings. Let me know 
> if you want to have the testresults in a different format or noted 
> somewhere else.
> 
> test of Forrest 0.7 rc1
> testing environment:
> Hardware: Acer Travelmate 4001 WLMI running Ubuntu "Hoary"
> #uname -a
> Linux acer-ubuntu 2.6.10-5-386 #1 Tue Jun 7 08:26:42 UTC 2005 i686 GNU/Linux
> #java -version
> java version "1.5.0_02"
> Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_02-b09)
> Java HotSpot(TM) Client VM (build 1.5.0_02-b09, mixed mode, sharing)
> 
> - Downloading and unpacking the tarball went without a problem
> - created FORREST_HOME environment variables
> - cd to forrest/site-author
> - do forrest run
> - open browser with localhost:8888
> - site is shown in the browser.
> 
> - cd to forrest/site-author
> - do forrest
> [note: the build was broken off due to an error. Could not find the 
> error. Is there a log where I can find in detail the messages that were 
> generated during the build?]

They are just broken internal site: links so the best way is to
look at the "brokenlinks.xml" (its location is shown just before
Cocoon starts running). If they were more complex errors then
yes there are logfiles if you are feeling brave:
http://forrest.apache.org/faq.html#logs

> - open index.html in a browser
> - site is shown in the browser
> - randomly selected PDF's opened in xpdf.
> 
> Will do a more thorough test later.

Thanks would be great thnaks.

-David

Mime
View raw message