forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ron Blaschke <mailing-li...@rblasch.org>
Subject Re: [Testing 0.7rc1] Calling site from ant may not download plugin
Date Fri, 17 Jun 2005 18:34:06 GMT
Friday, June 17, 2005, 11:54:47 AM, Ross Gardler wrote:
> Ron Blaschke wrote:
>> Unable to retrieve the ${plugin.name} plugin.
>>
>> Two noteworthy things: Calling "forrest init-plugins" installs the
>> plugin sucessfully.  And the error message says "${plugin.name}",
>> instead of the real name of the plugin.

> The two things are related. It looks like that the {plugin.name} is not
> being set for some reason (and I guess {versioned.name} is not set either.

> These are set in the init-plugins target of targets/plugins.xml

I ran my build.xml with "ant -d," and found the following:

  Setting ro project property: plugin.name -> ${plugin.name}
  Setting ro project property: plugin.version -> ${plugin.version}
  Setting ro project property: versioned.name ->
org.apache.forrest.plugin.input.projectInfo

"forrest -d" says:

  Setting ro project property: plugin.name ->
org.apache.forrest.plugin.input.projectInfo
  Setting ro project property: plugin.version ->
  Setting ro project property: versioned.name ->
org.apache.forrest.plugin.input.projectInfo

My forrest.properties says this:

  project.required.plugins=org.apache.forrest.plugin.input.projectInfo,
org.apache.forrest.plugin.input.simplifiedDocbook

Out of curiosity, I added the plugin version.

  project.required.plugins=org.apache.forrest.plugin.input.projectInfo-0.1,
org.apache.forrest.plugin.input.simplifiedDocbook

The debug trace of my build.xml changes to the following, and the
plugin is successfully installed.

  Setting ro project property: plugin.name ->
org.apache.forrest.plugin.input.projectInfo
  Setting ro project property: plugin.version -> 0.1
  Setting ro project property: versioned.name ->
org.apache.forrest.plugin.input.projectInfo-0.1

> I have no idea why this is happening and don't have the time to explore
> this just yet. I can't raise an issue either since the issue tracker is
> down right now.

I hope it's alright for everyone that I am thinking out loud here.  If
not, please tell me so.

If you think that I really found a bug, and not just made a stupid
mistake, I'll gladly create an issue myself, and try to help resolving
it.

> If we don't get time to fix this before the release I suggest adding a
> warning to the your-project.html in the instructions for using Forrest
> via Ant (i.e. you must manually install the plugins for it to work).

Yup, this will be fine.

Ron











Mime
View raw message