forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ross Gardler (JIRA)" <j...@apache.org>
Subject [jira] Updated: (FOR-241) character entities (e.g. ampersand) are expanded again for href or src attributes
Date Sat, 18 Jun 2005 09:34:17 GMT
     [ http://issues.apache.org/jira/browse/FOR-241?page=all ]

Ross Gardler updated FOR-241:
-----------------------------

    Fix Version: 0.8
                     (was: 0.7-dev)
    Description: 
If I have a url like this inside the XML source:

http://sourceforge.net/sflogo.php?group_id=comics-grabber&type=1

validate-xdocs fails because it wants the literal & to be typed out as
& instead. So I correct it to become:

http://sourceforge.net/sflogo.php?group_id=comics-grabber&type=1

However, the generated HTML has the entity resolution UNDONE!:

http://sourceforge.net/sflogo.php?group_id=comics-grabber&type=1

This HTML fails validation as 4.01 transitional.

David Crossley adds:
There is a demonstration of the problem in the document
src/documentation/content/xdocs/docs/dreams.xml
The ampersand in the link element text is properly handled but
the ampersand in the link href attribute is not.

  was:
If I have a url like this inside the XML source:

http://sourceforge.net/sflogo.php?group_id=comics-grabber&type=1

validate-xdocs fails because it wants the literal & to be typed out as
&amp; instead. So I correct it to become:

http://sourceforge.net/sflogo.php?group_id=comics-grabber&amp;type=1

However, the generated HTML has the entity resolution UNDONE!:

http://sourceforge.net/sflogo.php?group_id=comics-grabber&type=1

This HTML fails validation as 4.01 transitional.

David Crossley adds:
There is a demonstration of the problem in the document
src/documentation/content/xdocs/docs/dreams.xml
The ampersand in the link element text is properly handled but
the ampersand in the link href attribute is not.

        Version: 0.7-dev
    Environment: 

> character entities (e.g. ampersand) are expanded again for href or src attributes
> ---------------------------------------------------------------------------------
>
>          Key: FOR-241
>          URL: http://issues.apache.org/jira/browse/FOR-241
>      Project: Forrest
>         Type: Bug
>   Components: Core operations
>     Versions: 0.7-dev, 0.6
>     Reporter: Diwaker Gupta
>      Fix For: 0.8

>
> If I have a url like this inside the XML source:
> http://sourceforge.net/sflogo.php?group_id=comics-grabber&type=1
> validate-xdocs fails because it wants the literal & to be typed out as
> & instead. So I correct it to become:
> http://sourceforge.net/sflogo.php?group_id=comics-grabber&type=1
> However, the generated HTML has the entity resolution UNDONE!:
> http://sourceforge.net/sflogo.php?group_id=comics-grabber&type=1
> This HTML fails validation as 4.01 transitional.
> David Crossley adds:
> There is a demonstration of the problem in the document
> src/documentation/content/xdocs/docs/dreams.xml
> The ampersand in the link element text is properly handled but
> the ampersand in the link href attribute is not.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message