forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Johannes Schaefer <johannes.schae...@uidesign.de>
Subject Re: Encoding-atribute in site.xml (copied from user list)
Date Tue, 10 May 2005 13:15:54 GMT
There is a related FAQ entry:
   http://forrest.apache.org/0.7/docs/faq.html#encoding

Johannes


Ferdinand Soethe wrote:
> 
> Ross Gardler wrote:
> 
> RG> Since the template files do use UTF-8 it makes sense for them to be
> RG> defined as using UTF-8.
> 
> Agreed. No harm done in making it explicit.
> 
> RG> No it is not an editor problem. In the absence of an encoding attribute
> RG> the editor will assume a certain type of encoding. What this assumption
> RG> is would be dependant on the local settings of the editor (in some cases
> RG> this means the settings of the Operating System).
> 
> Just for the sake of the argument :-)
> 
> I just looked this up in some of my references and they
> state that an xml-file without encoding attribute is utf-8 or
> utf-16 (depending on the byte order mark).
> 
> Which to me means that xml-editors that assume something else are not
> conforming to the xml-standards. Or am I missing something?
> 
> --
> Ferdinand Soethe
> 
> 


-- 
User Interface Design GmbH * Teinacher Str. 38 * D-71634 
Ludwigsburg
Fon +49 (0)7141 377 000 * Fax  +49 (0)7141 377 00-99
Geschäftsstelle: User Interface Design GmbH * 
Lehrer-Götz-Weg 11 * D-81825 München
www.uidesign.de

Buch "User Interface Tuning" von Joachim Machate & Michael 
Burmester
www.user-interface-tuning.de

Mime
View raw message