forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From iss...@cocoondev.org
Subject [JIRA] Assigned: (FOR-502) Forrest Plugin in eclipse 3.0.2 requires FORREST_HOME path set but it is not handled properly
Date Tue, 24 May 2005 10:38:55 GMT
Message:

   The following issue has been re-assigned.

   Assignee: Ross Gardler (mailto:ross@saafe.org)
---------------------------------------------------------------------
View the issue:
  http://issues.cocoondev.org//browse/FOR-502

Here is an overview of the issue:
---------------------------------------------------------------------
        Key: FOR-502
    Summary: Forrest Plugin in eclipse 3.0.2 requires FORREST_HOME path set but it is not
handled properly
       Type: Bug

     Status: Open
   Priority: Critical

    Project: Forrest
 Components: 
             Tool: Eclipse config
   Versions:
             0.6
             0.7-dev

   Assignee: Ross Gardler
   Reporter: Praveen Bhatia

    Created: Mon, 23 May 2005 8:08 PM
    Updated: Tue, 24 May 2005 5:37 AM
Environment: eclipse 3.0.2, Forrest 0.7

Description:
I could export the plugin to eclipse. The 'seed' and 'new xdoc' option for the site menuitem
worked. However, Trying, to run the forrest xdoc files in server, gives error......

First, eclipse forrest plugin asks the preferences for forrest home to be set for the plugin.

Now if we set c:\forrest as the Forrest Home, it can locate the forrest.build.xml, but then
gives the following error from the server:
CASE 1: If we set FORREST_HOME=C:\forrest in preferences and the FORREST_HOME variable in
cmd shell:
==>
C:\forrest\main\forrest.build.xml:63: C:\forrest\main\"C:\forrest"\lib\core
not found.
at
org.apache.tools.ant.types.AbstractFileSet.getDirectoryScanner(AbstractFileS
et.java:342)
at org.apache.tools.ant.types.Path.list(Path.java:331)

CASE 2: To avoid the above problem, left the cmd line setting blank.
However, this also gives error. Error when FORREST_HOME is left blank in cmd shell, but set
as c:\forrest in the preferences ==>
C:\forrest\main\forrest.build.xml:63:
C:\forrest\main\{$env.FORREST_HOME}"\lib\core not found.
at
org.apache.tools.ant.types.AbstractFileSet.getDirectoryScanner(AbstractFileS
et.java:342)
at org.apache.tools.ant.types.Path.list(Path.java:331)

============================



---------------------------------------------------------------------
JIRA INFORMATION:
This message is automatically generated by JIRA.

If you think it was sent incorrectly contact one of the administrators:
   http://issues.cocoondev.org//secure/Administrators.jspa

If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira


Mime
View raw message