forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject [JIRA] Commented: (FOR-336) Table alignment problem with pelt and IE
Date Thu, 19 May 2005 02:25:55 GMT
The following comment has been added to this issue:

     Author: Addison Berry
    Created: Wed, 18 May 2005 9:24 PM
Ok, this is simpler and hides from Moz properly.

#content table {
  border: 0;
  width: 100%;
/*Hack to get IE to render the table at 100%*/
* html #content table { margin-left: -3px; }

View this comment:

View the issue:

Here is an overview of the issue:
        Key: FOR-336
    Summary: Table alignment problem with pelt and IE
       Type: Bug

     Status: Unassigned
   Priority: Minor

    Project: Forrest
             Skins (general issues)

   Reporter: Stefano Mancarella

    Created: Wed, 27 Oct 2004 8:51 AM
    Updated: Wed, 18 May 2005 9:24 PM
Environment: Forrest 0.6
Internet Explorer 6.0

There's a strange (css?) problem using tables with the pelt skin and viewing the result in
If a page contains a table, the table itself always starts below the menu in IE.
So if the table is among the first elements of the page and the menu is long, the result is
a blank space before the table itself.
To reproduce the problem do a forrest seed, add a <table> to index.xml (just below the
<body> tag) and see the result in IE.

The problem doesn't show up in browsers of the Mozilla family, so maybe it's due to a bug
in IE.

Tested with both 0.6 and trunk.

This message is automatically generated by JIRA.

If you think it was sent incorrectly contact one of the administrators:

If you want more information on JIRA, or have a bug to report see:

View raw message