forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ross Gardler <>
Subject Re: plugin naming convention
Date Mon, 04 Apr 2005 19:40:54 GMT
David Crossley wrote:
> I see that many of our plugins, even new ones, are not using
> the naming convention.
> ... snipped from plugins/pluginInfrastructure.html
> -------------
> org.apache.forrest.plugin.PLUGINNAME
> net.sf.forrestPlugins.PLUGINNAME
> In addition the name of the plugin should indicate the type of plugin  it is:
> NAME-input
> NAME-output
> NAME-internal
> -------------
> Should we amend the existing names before the 0.7 release?
> Should we get plugins/build.xml seedPlugin target to
> append the -$type part.

I forgot I'd written that ;-)

The practice I have been following is that if it is an input plugin then 
it need not have the extension (given that most plugins are input.

However, this is probably not ideal since it is an exception to the rule.

I'd say that, for the 0.7 release we should make all the names conform 
to the documented standard and deprecate all the old plugins (this is OK 
since the plugin infrastructure is part of the 0.7-dev work).

The idea of changing the build target is an excellent one too.


View raw message