forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject possible entity resolver failure (Was: svn commit: r164099)
Date Fri, 22 Apr 2005 15:15:57 GMT
Ross Gardler wrote:
> David Crossley wrote:
> >Ross Gardler wrote:
> >
> >>David Crossley wrote:
> >>
> >>>I don't understand what you mean Ross. It already works for me,
> >>>the catalog entity resolver finds the local "status DTD".
> >>>
> >>>That can be proved that by changing the publicIdentifier
> >>>in status.xml to be deliberately broken, then it fails
> >>>as it should,
> >>>e.g. ...  PUBLIC "-//APACHE//DTD Status Foo-Bust V1.3//EN"
> >>
> >>Well it isn't working for me. Forrest appears to not be resolving the 
> >>catalogs since it is looking in the local directory for the DTD.
> >>
> >>This happens for the projectInfo, OpenOffice.org and simplified-docbook 
> >>plugins.
> >>
> >>Any ideas?
> >
> >How are you invoking forrest?
> >If it is in the plugins directory using
> >'forrest/tools/ant/bin/ant test'
> >then did you remember the recent discussion
> >about the system Ant libs missing resolver.jar
> >http://forrest.apache.org/0.7/docs/howto/howto-buildPlugin.html#ant
> 
> Yep, I have xml-commons-resolver,jar in my ant lib directory.
> 
> It occurs however I run forrest:
> 
> ant test
> forrest site
> forrest run
> 
> I just verified I was at the latest release of Forrest, and did a clean 
> build (somehow I always forget to do that). But no change.

So does the entity resolver also fail for you with all
the normal processing, e.g. in forrest/site-author
doing 'forrest site'?

Please switch the verbosity level to 10 in
WEB-INF/xconf/forrest-core.xconf and send me
the output.

Does this problem occur for anyone else?

--David

Mime
View raw message