forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: Differents between 'forrest' and 'forrest run'
Date Mon, 04 Apr 2005 10:41:30 GMT
Thorsten Scherler wrote:
> David Crossley wrote:
> > Thorsten Scherler wrote:
> > > Hello devs,
> > > 
> > > trying to deploy the view and leather plugin I found a weird thing
> > > happening:
> > > 
> > > Doing 'forrest run' brings the site rendered by the plugins, but doing
> > > 'forrest' will use the "normal" skin.
> > > 
> > > How come? How can I fix that?
> > > 
> > > Any ideas?
> > 
> > What do i need to do to replicate the issue here?
> > Do i just add to those plugins to forrest.properties
> > "project.required.plugins" and change "project.skin"?
> > 
> 
> project.skin -> should get ignored by the plugins! I am still using
> skinit pipes but they can now come from pelt.
> 
> project.required.plugins-> org....leather, org...view, org...
> 
> Just do 
> 1) svn up in {forrest}/plugins
> 2) cd org...leather; ant local-deploy
> 3) cd org...view; ant local-deploy
> 4) in e.g. org...view 'forrest' and then 'forrest run'
> 
> You will see the plugin get rendered by 'forrest' with the pelt skin in
> build/site. If you now turn to 'forrest run' instance you find a
> complete different skin.

I get different behaviour. I see the same skins in both.
It looks like the pelt skin.

> Now I just did a 'forrest' on a fresh seed where I add both plugins
> (like you stated) and it is working just fine (static/dynamic show the
> same). It seems only to be a problem in the plugin which is a bummer
> because I cannot deploy them. :( 

It breaks for me in both methods ...
-----------
/svn/asf/forrest/build/plugins/org.apache.forrest.plugin.view/src/documentation/default.fv
(No such file or directory
-----------

Perhaps you have some un-committed files.

--David

Mime
View raw message