forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ferdinand Soethe <samm...@soethe.net>
Subject problems with rtf-output plugin
Date Mon, 28 Mar 2005 17:29:07 GMT
Tried to run some tests with the rtf-plugin today.
To get started I tried to run forrest on the sample documents.

I followed the instructions in the readme.txt saying

 - copy the "rtf-output" plugin directory to forrest/build/plugins
 - copy the WEB-INF directory to forrest/main/webapp
   (I did not copy the .svn subdir)
 - add "rtf-output" (without quotes) to your projects "project.required.plugins"
   property


Then I ran a forrest on the plugin-directory.
and had this error logged:

DEBUG   2005-03-28 19:21:11.924 [jfor.log] (): Attempt to load class 'org.apache.cocoon.serializatio
n.RTFSerializer'successful, runningUnderCocoon()=true
INFO    2005-03-28 19:21:11.944 [jfor.con] (): jfor V0.7.2rc1 - setting up conversion...
INFO    2005-03-28 19:21:11.974 [jfor.con] (): Parsing xsl:fo document...
X [0]                                     samples/minimal.rtf   BROKEN: Streaming of an internal
pip
eline is not possible with a reader.
X [0]                                     index.pdf     BROKEN: No pipeline matched request:
index.p
df
* [36/0]    [0/0]     0.07s  229b    skin/images/rc-b-r-5-1header-2tab-selected-3tab-selected.png
Logging Error: Writing event to closed stream.

What exactly does

> BROKEN: Streaming of an internal pipeline is not possible with a reader.

refer to. Is this a bug?



--
Ferdinand Soethe


Mime
View raw message