forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ross Gardler <rgard...@apache.org>
Subject Re: problems with rtf-output plugin
Date Wed, 30 Mar 2005 23:55:27 GMT
Ferdinand Soethe wrote:
> Tried to run some tests with the rtf-plugin today.
> To get started I tried to run forrest on the sample documents.
> 
> I followed the instructions in the readme.txt saying
> 

As the readme says, this plugin is pre-alpha. It does not currently work 
correctly.

With that in mind...

> Then I ran a forrest on the plugin-directory.
> and had this error logged:
> 
> DEBUG   2005-03-28 19:21:11.924 [jfor.log] (): Attempt to load class 'org.apache.cocoon.serializatio
> n.RTFSerializer'successful, runningUnderCocoon()=true
> INFO    2005-03-28 19:21:11.944 [jfor.con] (): jfor V0.7.2rc1 - setting up conversion...
> INFO    2005-03-28 19:21:11.974 [jfor.con] (): Parsing xsl:fo document...
> X [0]                                     samples/minimal.rtf   BROKEN: Streaming of
an internal pip
> eline is not possible with a reader.
> X [0]                                     index.pdf     BROKEN: No pipeline matched request:
index.p
> df
> * [36/0]    [0/0]     0.07s  229b    skin/images/rc-b-r-5-1header-2tab-selected-3tab-selected.png
> Logging Error: Writing event to closed stream.
> 
> What exactly does
> 
> 
>>BROKEN: Streaming of an internal pipeline is not possible with a reader.

No idea.

Have you tried doing forrest run and clicking the link to minimal.rtf? 
According to the readme this is the only file that works (it doesn't say 
you have to use forrest run, but since forrest site doesn't work I guess 
that you do need to).

I think this plugin should move from here into the whiteboard, we do not 
want people to get the impression that it is even close to workable.

Ross

Mime
View raw message