forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ross Gardler <rgard...@apache.org>
Subject Re: [ProjectInfo Plugin] Action layout no more taken into account...
Date Thu, 17 Mar 2005 17:54:16 GMT
Cyriaque Dupoirieux wrote:
> I updated these style sheets :
> 
> $FORREST_HOME/plugins/org.apache.forrest.plugin.projectInfo/resources/stylesheets/changes2document.xsl

> 
> and
> $FORREST_HOME/plugins/org.apache.forrest.plugin.projectInfo/resources/stylesheets/todo2document.xsl

> 

They are the right files. I can assure you there is nothing wrong with 
the local-deploy target as we've been using it to do exactly this kind 
of change for some time.

You can verify this for yourself if you make your changes, do "ant 
local-deploy" and check the files in FORREST_HOME/build/plugins/. You 
should see your changes in those files.

Assuming that I am correct and the files are being deployed this only 
leaves me with one of two thoughts:

1) your XSL is not correct
2) I've made some mistake in moving the code from core and in the plugin 
is not actually being used.

You can verify 2 by making some simply, but obvious, change to one of 
the XSL's - perhaps have it add "It's Working" to the title.

If that works then we'll need to see your XSL.

Ross

> 
> 
> Ross Gardler a écrit :
> 
>> Cyriaque Dupoirieux wrote:
>>
>>> Hi,
>>>
>>>    I think that there is a problem with ant local-deploy target :
>>>
>>>    * I had the ProjectInfo plug in which was generating well my pages,
>>>    * I changed a few things in a style sheet and make a local-deploy to
>>>      take them into account,
>>>    * The layout - <ul><li>... in my actions are lost.
>>>    * Then I get back the original file and make a local-deploy again,
>>>    * The layout - <ul><li>... in my actions are still lost.
>>>
>>>
>>>    Is there something I did not understand ?
>>
>>
>>
>> What stylesheet file are you editing?
>>
>> Ross
>>
>>
> 
> 



Mime
View raw message