forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From iss...@cocoondev.org
Subject [JIRA] Commented: (FOR-356) multi-user capability (Was: Solaris problem)
Date Sun, 06 Mar 2005 10:47:18 GMT
The following comment has been added to this issue:

     Author: Fabio Rinaldi
    Created: Sun, 6 Mar 2005 4:46 AM
       Body:
The original problem is solved. However (as already reported) there
is a (minor) new problem.

If someone wants to install forrest as 'root', and allow different
users to use it, then the following procedure is needed AFTER 
unpacking and build:

1. create the directory $FORREST_HOME/build/plugins
2. install all required plugins there

Notice that if the distributions contains the plugins (as it is the
case in the snapshots that I tried), the above procedure could be
automated simply by adding the following commands at the end of
'build.sh':

mkdir ../build/plugins
cp -R ../plugins/* ../build/plugins

Alternatively, it would be reasonable to allow users to specify
a local directory for their plugins. Perhaps this is already 
possible, and I did not notice... Please let me know if this 
is the case.

---------------------------------------------------------------------
View this comment:
  http://issues.cocoondev.org//browse/FOR-356?page=comments#action_12135

---------------------------------------------------------------------
View the issue:
  http://issues.cocoondev.org//browse/FOR-356

Here is an overview of the issue:
---------------------------------------------------------------------
        Key: FOR-356
    Summary: multi-user capability (Was: Solaris problem)
       Type: Bug

     Status: In Progress
   Priority: Major

    Project: Forrest
   Versions:
             0.6

   Assignee: Rick Tessner
   Reporter: Fabio Rinaldi

    Created: Mon, 8 Nov 2004 10:38 AM
    Updated: Sun, 6 Mar 2005 4:46 AM

Description:
Back in August I reported a problem about using Forrest in a
multi-user environment. I have recently downloaded Forrest 0.6 and
tried to install it on both a linux machine and a solaris system.

I have found that there is still a problem that prevents generic users
from using Forrest if installed as root. The problem is caused by an
attempt to write in the forrest source code file area. I don't know
which piece of code causes this error, but I have found that doing the
following can solve it:

chmod a+w $FORREST_HOME/context

This solved the problem on the linux system, but not on the solaris
system, because the filesystem where I have installed forrest is
mounted read-only. In order to permanently solve the problem, it would
be necessary to find the piece of code that requires write permissions
to $FORREST_HOME/context (and change it, since there should be no
reason to write there).



---------------------------------------------------------------------
JIRA INFORMATION:
This message is automatically generated by JIRA.

If you think it was sent incorrectly contact one of the administrators:
   http://issues.cocoondev.org//secure/Administrators.jspa

If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira


Mime
View raw message