forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From iss...@cocoondev.org
Subject [JIRA] Commented: (FOR-363) <figure>-elements within aggregated pdf-pages are not displayed
Date Fri, 25 Mar 2005 14:36:18 GMT
The following comment has been added to this issue:

     Author: Dick Hollenbeck
    Created: Fri, 25 Mar 2005 8:35 AM
       Body:
With 0.7 prerelease circa 23-March-2005 the problem is worse.  I cannot get <img> or
<figure> to show up in the wholesite.pdf even if putting the *.png file into the funky
places that made <img> work for 0.6.

This is a digression.
---------------------------------------------------------------------
View this comment:
  http://issues.cocoondev.org//browse/FOR-363?page=comments#action_12181

---------------------------------------------------------------------
View the issue:
  http://issues.cocoondev.org//browse/FOR-363

Here is an overview of the issue:
---------------------------------------------------------------------
        Key: FOR-363
    Summary: <figure>-elements within aggregated pdf-pages are not displayed
       Type: Bug

     Status: Unassigned
   Priority: Minor

    Project: Forrest
   Versions:
             0.6

   Assignee: 
   Reporter: Stephan E. Schlierf

    Created: Thu, 11 Nov 2004 2:03 AM
    Updated: Fri, 25 Mar 2005 8:35 AM
Environment: Linux

Description:
With Forrest 0.6 I encountered a problem during the creation of a pdf-file that is aggregated
from a group of documents:
All my graphics are in project-dir]/src/documentation/resources/images (and its subdiretories).
Now if I use <figure>-elements in these documents the graphics are not displayed in
the aggregated pdf-file. If I use <img>-elements everything's ok.
As far as I can see this problem is located in
src/core/context/resources/stylesheets/aggregates/doc2doc-uniqueids.xsl:
Around line 45 the follwoing template is defined:

<xsl:template match="section/document//figure|img[starts-with(@src, 
'my-images')]">
    <!-- fix my-images/** links, which break as they are not relative to the 
site root -->
...
</xsl:template>

If you change the match condition to

match="section/document//figure[starts-with(@src, 'my-images')]|
img[starts-with(@src, 'my-images')]">

even the <figure>-elements are displayed.


---------------------------------------------------------------------
JIRA INFORMATION:
This message is automatically generated by JIRA.

If you think it was sent incorrectly contact one of the administrators:
   http://issues.cocoondev.org//secure/Administrators.jspa

If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira


Mime
View raw message