forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From iss...@cocoondev.org
Subject [JIRA] Closed: (FOR-356) multi-user capability (Was: Solaris problem)
Date Sun, 06 Mar 2005 11:20:18 GMT
Message:

   The following issue has been closed.

   Resolver: Ross Gardler
       Date: Sun, 6 Mar 2005 5:20 AM

(the folowing comments are copied here for completeness on this issue, however, they relate
to a different issue to this one, therefore a new issue has been opened for-462)

If Forrest is installed in a multi-user environemnt then each user should still have their
own version of the plugins. This is because they may need a different version to different
users (not an issue right now as there is only one version of each plugin, however, this will
not always be the case.

In this situation the user should be able to change change the location of the Forrest plugins
directory on a per project basis.

---

With respect to using plugins that are available in source form see FOR-388

---------------------------------------------------------------------
View the issue:
  http://issues.cocoondev.org//browse/FOR-356

Here is an overview of the issue:
---------------------------------------------------------------------
        Key: FOR-356
    Summary: multi-user capability (Was: Solaris problem)
       Type: Bug

     Status: Closed
   Priority: Major
 Resolution: FIXED

    Project: Forrest
   Fix Fors:
             0.7
   Versions:
             0.6

   Assignee: Rick Tessner
   Reporter: Fabio Rinaldi

    Created: Mon, 8 Nov 2004 10:38 AM
    Updated: Sun, 6 Mar 2005 5:20 AM

Description:
Back in August I reported a problem about using Forrest in a
multi-user environment. I have recently downloaded Forrest 0.6 and
tried to install it on both a linux machine and a solaris system.

I have found that there is still a problem that prevents generic users
from using Forrest if installed as root. The problem is caused by an
attempt to write in the forrest source code file area. I don't know
which piece of code causes this error, but I have found that doing the
following can solve it:

chmod a+w $FORREST_HOME/context

This solved the problem on the linux system, but not on the solaris
system, because the filesystem where I have installed forrest is
mounted read-only. In order to permanently solve the problem, it would
be necessary to find the piece of code that requires write permissions
to $FORREST_HOME/context (and change it, since there should be no
reason to write there).



---------------------------------------------------------------------
JIRA INFORMATION:
This message is automatically generated by JIRA.

If you think it was sent incorrectly contact one of the administrators:
   http://issues.cocoondev.org//secure/Administrators.jspa

If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira


Mime
View raw message