forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject [JIRA] Commented: (FOR-356) multi-user capability (Was: Solaris problem)
Date Tue, 22 Feb 2005 13:42:32 GMT
The following comment has been added to this issue:

     Author: Fabio Rinaldi
    Created: Tue, 22 Feb 2005 7:42 AM

> Regarding the first part of the suggestion. That is not possible 
> at the moment, because 'build clean' would remove it. Perhaps we 
> should just have an FAQ about mult-user systems. 

It might be sufficient to add the following line at the end of

mkdir ../build/plugins

Anyway, since the plugins are included in the archive file, it might
be easier to do:

mv ../plugins ../build

If the above is added at the end of main/, then the process
of installation is reduced to two steps (even in a multi-user 
environment) to be performed by the system administrator:

1. unpack the archive in the directory of choice
2. cd main;

This works fine (just tested on a solaris system).

However, I then tried to remove the pdf plugin, and was expecting
to receive the usual friendly message about missing plugin when
creating a site as a regular user. Instead I got the following
(which is not very helpful):

/opt/apache/forrest/main/targets/plugins.xml:246: The following error occurred while executing
this line:
/opt/apache/forrest/main/targets/plugins.xml:249: The following error occurred while executing
this line:
/opt/apache/forrest/main/targets/plugins.xml:169: The <var> type doesn't support the
"depends" attribute.

I guess this is the effect of some recent change?

View this comment:

View the issue:

Here is an overview of the issue:
        Key: FOR-356
    Summary: multi-user capability (Was: Solaris problem)
       Type: Bug

     Status: In Progress
   Priority: Major

    Project: Forrest

   Assignee: Rick Tessner
   Reporter: Fabio Rinaldi

    Created: Mon, 8 Nov 2004 10:38 AM
    Updated: Tue, 22 Feb 2005 7:42 AM

Back in August I reported a problem about using Forrest in a
multi-user environment. I have recently downloaded Forrest 0.6 and
tried to install it on both a linux machine and a solaris system.

I have found that there is still a problem that prevents generic users
from using Forrest if installed as root. The problem is caused by an
attempt to write in the forrest source code file area. I don't know
which piece of code causes this error, but I have found that doing the
following can solve it:

chmod a+w $FORREST_HOME/context

This solved the problem on the linux system, but not on the solaris
system, because the filesystem where I have installed forrest is
mounted read-only. In order to permanently solve the problem, it would
be necessary to find the piece of code that requires write permissions
to $FORREST_HOME/context (and change it, since there should be no
reason to write there).

This message is automatically generated by JIRA.

If you think it was sent incorrectly contact one of the administrators:

If you want more information on JIRA, or have a bug to report see:

View raw message