forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From iss...@cocoondev.org
Subject [JIRA] Commented: (FOR-356) multi-user capability (Was: Solaris problem)
Date Mon, 21 Feb 2005 23:33:32 GMT
The following comment has been added to this issue:

     Author: Fabio Rinaldi
    Created: Mon, 21 Feb 2005 5:33 PM
       Body:
I have installed (on a linux system) a 0.7-dev version
(forrest_20050221174408.tar.gz) and confirm that the
problem no longer exist.

However, there is a new one:

BUILD FAILED
/opt/apache/forrest/main/targets/plugins.xml:229: Directory /opt/apache/forrest/build/plugins
creation was not successful for an unknown reason

This again is caused by forrest trying to create the "plugins"
directory and not having permissions for it. The problem can
be solved by creating the directory manually. As a way to avoid
this little problem, I suggest including an empty "build/plugins"
directory in the forrest package.

This of course does not solve it completely, as the user
is left with the task of manually installing the plugins.
However, there is a nice explanatory message now that clarifies
the problem and how to solve it:

> Unable to download the "org.apache.forrest.plugin.pdf-output" 
> plugin from http://forrest.apache.org/plugins/.
> [...]
> To manually install a plugin download the plugin zip file from
> http://forrest.apache.org/plugins/ and  extract it into to 
> /opt/apache/forrest/build/plugins//org.apache.forrest.plugin.pdf-output.

Btw, it might be trivial, but I suggest to remove the final dot from
the message above, because it might appear to belong to the path 
(which is wrong).

---------------------------------------------------------------------
View this comment:
  http://issues.cocoondev.org//browse/FOR-356?page=comments#action_12062

---------------------------------------------------------------------
View the issue:
  http://issues.cocoondev.org//browse/FOR-356

Here is an overview of the issue:
---------------------------------------------------------------------
        Key: FOR-356
    Summary: multi-user capability (Was: Solaris problem)
       Type: Bug

     Status: In Progress
   Priority: Major

    Project: Forrest
   Versions:
             0.6

   Assignee: Rick Tessner
   Reporter: Fabio Rinaldi

    Created: Mon, 8 Nov 2004 10:38 AM
    Updated: Mon, 21 Feb 2005 5:33 PM

Description:
Back in August I reported a problem about using Forrest in a
multi-user environment. I have recently downloaded Forrest 0.6 and
tried to install it on both a linux machine and a solaris system.

I have found that there is still a problem that prevents generic users
from using Forrest if installed as root. The problem is caused by an
attempt to write in the forrest source code file area. I don't know
which piece of code causes this error, but I have found that doing the
following can solve it:

chmod a+w $FORREST_HOME/context

This solved the problem on the linux system, but not on the solaris
system, because the filesystem where I have installed forrest is
mounted read-only. In order to permanently solve the problem, it would
be necessary to find the piece of code that requires write permissions
to $FORREST_HOME/context (and change it, since there should be no
reason to write there).



---------------------------------------------------------------------
JIRA INFORMATION:
This message is automatically generated by JIRA.

If you think it was sent incorrectly contact one of the administrators:
   http://issues.cocoondev.org//secure/Administrators.jspa

If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira


Mime
View raw message