forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Upayavira ...@upaya.co.uk>
Subject Re: Forrest 0.6.x, Cocoon and Java
Date Mon, 10 Jan 2005 10:12:09 GMT
Rick Tessner wrote:

>Hi all,
>
>I've been looking at the best way to upgrade cocoon in the
>forrest_06_branch in order to address
>http://issues.cocoondev.org//browse/FOR-356 (Multi-User Capability).  
>
>The problem was a cocoon issue which has been fixed in both Cocoon
>2.2-dev and Cocoon 2.1.6 (and thus Cocoon 2.1.7-dev)
>
>Issues that I've run across
>
>      * Current Cocoon 2.2-dev (and that used in Forrest 0.7-dev) works
>        only with Java 1.4.x or higher. 
>      * Cocoon 2.1.6 works with Java 1.3.x and higher 
>      * Cocoon 2.1.7-dev I can't get to compile with either Java 1.3.x
>        or 1.4.x (bombs in different places tho) so I don't know whether
>        it works with Forrest. :(
>      * The pass-through attribute for the map:mount element in the
>        sitemap does not work under Cocoon 2.1.6 (may work in 2.1.7-dev,
>        but again I haven't been able to test this)
>      * Forrest 0.6 currently uses an earlier revision of Cocoon 2.2-dev
>        (which was at the time compatible with Java 1.3.x) with Cocoon
>        2.1.5 libs.
>
>My Preference:
>
>      * Upgrade Cocoon in forrest_06_branch to the same Cocoon being
>        used in the Forrest trunk and make it clear that Java 1.4.x is
>        the minimum requirement for Forrest (both 0.6.x and svn trunk).
>        ie. Upgraded to Cocoon 2.2-dev, revision 111170.
>      * Upgrade the java classes in Forrest 0.6.x that were part of
>        o.a.cocoon to o.a.forrest to mirror what has been done in
>        Forrest 0.7-dev.
>      * Upgrade both 0.6.1-dev and 0.7-dev to Cocoon 2.2 when it's
>        released.  Discussion on the cocoon dev mailing list sounds like
>        that could happen in the next 3-4 months.
>
>If we go with Cocoon 2.2, it would mean that we lose Java 1.3.x
>compatibility.  Then again, Java 1.3 is in the process of being EOL'd.
>See http://java.sun.com/j2se/1.3/download.html .
>  
>
Or, look into what the issues in 2.2 and Java 1.3 are. While 2.2 is 
going to be 1.4 only, there's no reason why any current issues can't be 
fixed if there are volunteers wanting to do it - i.e. make 2.2 
compatible with 1.3 again.

Regards, Upayavira

Mime
View raw message