forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From iss...@cocoondev.org
Subject [JIRA] Commented: (FOR-422) forrestbot-webapp gives IOException
Date Sat, 22 Jan 2005 04:55:16 GMT
The following comment has been added to this issue:

     Author: David Crossley
    Created: Fri, 21 Jan 2005 10:54 PM
       Body:
I don't profess to understand the code, but commenting out the following section fixes the
problem ...

----------------
class ExecutorThread extends Thread {
...
...
        public void run() {
        StreamGobbler errorGobbler = new StreamGobbler(proc.getErrorStream(), Priority.ERROR);
        errorGobbler.start();
                StreamGobbler outputGobbler = new StreamGobbler(proc.getInputStream(), Priority.DEBUG);
                outputGobbler.start();
/*
                try {
                        proc.getInputStream().close();
                        proc.getErrorStream().close();
                        proc.getOutputStream().close();
                } catch (IOException ioe) {
                        log.error("couldn't close process's input/output streams", ioe);
                }
*/
        }
----------------
---------------------------------------------------------------------
View this comment:
  http://issues.cocoondev.org//browse/FOR-422?page=comments#action_12002

---------------------------------------------------------------------
View the issue:
  http://issues.cocoondev.org//browse/FOR-422

Here is an overview of the issue:
---------------------------------------------------------------------
        Key: FOR-422
    Summary: forrestbot-webapp gives IOException
       Type: Bug

     Status: Unassigned
   Priority: Major

    Project: Forrest
 Components: 
             Forrestbot
   Versions:
             HEAD

   Assignee: 
   Reporter: David Crossley

    Created: Wed, 19 Jan 2005 10:33 PM
    Updated: Fri, 21 Jan 2005 10:54 PM
Environment: debian linux

Description:
The Forrestbot webapp interface enables the login okay.
However when trying to Build or Deploy a site, then
nothing happens, and an IOException is reported.


---------------------------------------------------------------------
JIRA INFORMATION:
This message is automatically generated by JIRA.

If you think it was sent incorrectly contact one of the administrators:
   http://issues.cocoondev.org//secure/Administrators.jspa

If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira


Mime
View raw message