forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject [JIRA] Commented: (FOR-356) multi-user capability (Was: Solaris problem)
Date Fri, 12 Nov 2004 02:43:38 GMT
The following comment has been added to this issue:

     Author: Rick Tessner
    Created: Thu, 11 Nov 2004 8:41 PM
Just tried this and here's the error that I'm seeing.  This is under Linux with Forrest 0.6
downloaded from
I did a "forrest seed" followed by a "forrest site" and here's the error tha occurs once the
build starts running cocoon (NOTE: a "forrest run" works just fine):
cocoon 2.2.0-dev
Copyright (c) 1999-2004 Apache Software Foundation. All rights reserved.
ERROR   2004-11-11 18:32:20.353 [        ] (): Directory '.' is not readable/writable
Exception in thread "main" Directory '.' is not readable/writable
        at org.apache.cocoon.bean.CocoonWrapper.getDir(
        at org.apache.cocoon.bean.CocoonWrapper.initialize(
        at org.apache.cocoon.bean.CocoonBean.initialize(         at org.apache.cocoon.Main.main(
/usr/local/apache-forrest-0.6/src/core/targets/site.xml:43: Java returned: 1
                                                                                 Total time:
8 seconds

View this comment:

View the issue:

Here is an overview of the issue:
        Key: FOR-356
    Summary: multi-user capability (Was: Solaris problem)
       Type: Bug

     Status: Unassigned
   Priority: Major

    Project: Forrest

   Reporter: Fabio Rinaldi

    Created: Mon, 8 Nov 2004 10:38 AM
    Updated: Thu, 11 Nov 2004 8:41 PM

Back in August I reported a problem about using Forrest in a
multi-user environment. I have recently downloaded Forrest 0.6 and
tried to install it on both a linux machine and a solaris system.

I have found that there is still a problem that prevents generic users
from using Forrest if installed as root. The problem is caused by an
attempt to write in the forrest source code file area. I don't know
which piece of code causes this error, but I have found that doing the
following can solve it:

chmod a+w $FORREST_HOME/context

This solved the problem on the linux system, but not on the solaris
system, because the filesystem where I have installed forrest is
mounted read-only. In order to permanently solve the problem, it would
be necessary to find the piece of code that requires write permissions
to $FORREST_HOME/context (and change it, since there should be no
reason to write there).

This message is automatically generated by JIRA.

If you think it was sent incorrectly contact one of the administrators:

If you want more information on JIRA, or have a bug to report see:

View raw message