forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ross Gardler <rgard...@apache.org>
Subject Re: errors with text-output plugin
Date Fri, 19 Nov 2004 13:21:45 GMT


Rick Tessner wrote:
> Diwaker Gupta wrote:
> 
>> After most recent svn update, I get errors like these:
>>
>> X [0]                                     projects/index.txt   BROKEN: 
>> /home/diwaker/shared/forrest/site/content/xdocs/projects/linkmap-index.xml 
>>
>> (No such file or directory)
> 
> 
> I just committed a fix for this.  The output.xmap for the plugins was 
> being mounted a bit to early in the sitemap.  I moved the <map:mount> 
> down to where the other output formats get mounted and this appears to 
> have resolved the problem.
> 
> Hopefully this was the right thing to do.  I'm not sure what the plan is 
> for the mounting of the various plugin .xmap files and this was just a 
> guess as to where the output one should go.
> 
> Ross, could you cross-check this for me?  Thanks Mr. Plugin Man! :)

Yeah, that seems to be the right place for it, but I must be losing my 
title if others are correcting my mistakes :-)), or is it :-(

Note I have added a test framework to each plugin now. Just do ant test 
in the plugin directory. This locally-deploys the plugin then builds the 
plugin docs. This showed up another error with the plugin relating to my 
recent extraction of the PDF stuff into a plugin.

It is now necessary to ether explicitly include the PDF plugin or to 
disable the pdf link in skinconf.xml.

The fbit stuff that Thorsten is working on will remove this limitation.

Ross

Mime
View raw message