forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clay Leeds <cle...@medata.com>
Subject Re: RAW files (was Re: xml-fop Build Failed)
Date Fri, 12 Nov 2004 18:46:30 GMT
I have yet to find a solution to this problem outlined below and also  
here[1]. I do not appear to be able to copy RAW files to my static site  
(*.fo, *.svg, & *.pdf).

Attempted solutions I have tried placing these files:

1. src/documentation/content/* (the 'old' pre-0.6 method)
    - src/documentation/content/svg/*.svg
    - src/documentation/content/fo/*.fo
    - src/documentation/content/dev/fo/*.pdf

RESULT:     JAVA CORE-DUMP ERROR (see [1])
   Exception in thread "main" java.lang.NoSuchMethodError:
   org.apache.batik.bridge.UnitProcessor.createContext(Lorg/apache/batik/
   bridge/BridgeContext;Lorg/w3c/dom/Element;)Lorg/apache/batik/util/
   UnitProcessor$Context;
   [..]

2. src/documentation/resources/images/* (the current method on  
http://forrest.apache.org)
    - src/documentation/resources/images/dev/svg/*.svg
    - src/documentation/resources/images/dev/fo/*.fo
    - src/documentation/resources/images/dev/fo/*.pdf

RESULT EXAMPLE:     BROKEN:  
/Users/Shared/_WebDLs/_repos/xml-fop/src/documentation/content/xdocs/ 
images/paints.xml (No such file or directory)

3. src/documentation/resources/images/* (messy, but if it works I'm  
happy!)
    - src/documentation/resources/images/*.svg
    - src/documentation/resources/images/*.fo
    - src/documentation/resources/images/*.pdf

RESULT EXAMPLE:     BROKEN:  
/Users/Shared/_WebDLs/_repos/xml-fop/src/documentation/content/xdocs/ 
images/paints.xml (No such file or directory)

4. src/documentation/content/xdocs/images/* (messy, but if it works I'm  
happy!)
    - src/documentation/content/xdocs/images/*.svg
    - src/documentation/content/xdocs/images/*.fo
    - src/documentation/content/xdocs/images/*.pdf

RESULT EXAMPLE:     BROKEN:  
/Users/Shared/_WebDLs/_repos/xml-fop/src/documentation/content/xdocs/ 
images/paints.xml (No such file or directory)

I'm open to suggestions on how to resolve this problem.

[1]
http://issues.apache.org/eyebrowse/ReadMsg? 
listName=dev@forrest.apache.org&msgNo=15274

Web Maestro Clay
-- 
Clay Leeds - <cleeds@medata.com>
Webmaster/Developer - Medata, Inc. - <http://www.medata.com/>
PGP Public Key: <https://mail.medata.com/pgp/cleeds.asc>


Mime
View raw message