forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From iss...@cocoondev.org
Subject [JIRA] Commented: (FOR-359) Compile error with OpenOffice-Document
Date Thu, 11 Nov 2004 15:42:38 GMT
The following comment has been added to this issue:

     Author: Ferdinand Soethe
    Created: Thu, 11 Nov 2004 9:42 AM
       Body:
Ross Gardler wrote

ico> I'm getting more confused. I don't understand why your
ico> feshly checked out Forrest is giving these errors:

Well even confused you seem to have a pretty good idea what to look
for.

ico> You output seems to indicate the plugin is being built
ico> correctly, but clearly something is going wrong. Do you have a
ico> sitemap.xmap file in your proect directory?

That seems to have been my sites problem. In scr/documentation was not
sitemap.xmap. I checked my backups from forrest 0.6 back to the
originally generated structure and it's been missing all the way.

So this should be created when upgrading a site from 0.6 to 0.7 or
should it have been there in 0.6 all along.

Anyhow. After doing a seed with 0.7 , copying the content tree into
this new site and adding the plugins in forrest.properties once more,
I can comile my site again. Yeah!

Thanks for that!

Although I also tried a forrest-site in plugins\OpenOffice.org\docs,
nd its still logging lots of errors. But that's a different problem I
guess?

Just since I already checked it, here the answer to your other
question.

ico> Can you check that forrest/build/plugins/sitemap.xmap
ico> contains the following (after you do a forrest site in the
ico> OpenOffice.org docs directory):

ico> <map:select type="exists">
ico>   <map:when test="{forrest:plugins}/OpenOffice.org/sitemap.xmap">
ico>   <map:mount uri-prefix=""  
ico> src="{forrest:plugins}/OpenOffice.org/sitemap.xmap"
ico> check-reload="yes" pass-through="true"/>
ico>   </map:when>
ico> </map:select

yes it does and is functionally the same:

<map:select type="exists">
<map:when test="{forrest:plugins}/OpenOffice.org/sitemap.xmap">
<map:mount uri-prefix="" src="{forrest:plugins}/OpenOffice.org/sitemap.xmap" check-reload="yes"
pass-through="true"/>
</map:when>
</map:select>

---------------------------------------------------------------------
View this comment:
  http://issues.cocoondev.org//browse/FOR-359?page=comments#action_11800

---------------------------------------------------------------------
View the issue:
  http://issues.cocoondev.org//browse/FOR-359

Here is an overview of the issue:
---------------------------------------------------------------------
        Key: FOR-359
    Summary: Compile error with OpenOffice-Document
       Type: Bug

     Status: Open
   Priority: Minor

    Project: Forrest
   Versions:
             0.7

   Assignee: Ross Gardler
   Reporter: Ferdinand Soethe

    Created: Tue, 9 Nov 2004 9:00 AM
    Updated: Thu, 11 Nov 2004 9:42 AM
Environment: Windows XP

Description:
After updating from Forrest 0.6 to yesterdays 0.7 snapshot my openoffice document will not
pass the compile runs.

The error message is a mystery to me:

Failed to create InputSource: file:/C:/Programme/forrest/main/webapp/resources/schema/open-office/dummy.dtd
X [0]                                     BookCrossing/bcdownloads.html BROKEN: java.io.FileNotFoundException:
P:\forrest\src\documentation\content\xdocs\BookCr
ossing\bcdownloads.sxw\office.dtd (Das System kann den angegebenen Pfad nicht finden)




---------------------------------------------------------------------
JIRA INFORMATION:
This message is automatically generated by JIRA.

If you think it was sent incorrectly contact one of the administrators:
   http://issues.cocoondev.org//secure/Administrators.jspa

If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira


Mime
View raw message