forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thorsten Scherler <thors...@apache.org>
Subject Re: Plugin questions
Date Wed, 24 Nov 2004 09:21:50 GMT
Cheers, Ross!

I just updated the docs and included:
<warning>
Please make sure that you are using forrest 0.7-dev 
if you want use plugins. Forrest 0.6 will not work!!!
</warning>

This way I will not make the same mistake three times ;-)

sorry for stealing your time and being such a dumb ass.

El mar, 23-11-2004 a las 19:03, Ross Gardler escribió:
> Thorsten Scherler wrote:
> > 2) I tried fbits plugin in webapp mod /forrest run/ and do get ressource
> > not found for all my matches declared in output.xmap. 
> 
> Working through your *.get matchers, the following work OK:
> 
> http://localhost:8888/static.get
> http://localhost:8888/contracts-dir-fbits.get
> http://localhost:8888/contracts-dir-nuggets.get
> http://localhost:8888/ft.get
> 
> The only one that fais is
> 
> http://localhost:8888/contracts.get
> 
> > When I use /ant test/ I get my *.get files created in the static site. 
> 
> For me ant test gives "Build Failed" because of the above contracts.get 
> failure
> 
> > Trying to say that the crawler is using the output.xmap but it seems
> > that the webapp is not.
> > 
> > Question: Why is happening?
> 
> according to my test results it is not happening. I am getting 
> consistent results for both forrest run and ant test (== forrest site).
> 
> Looking at the contracts.get matcher:
> 
> 
>      <map:match pattern="contracts.get">
>        <map:generate src="cocoon:/contracts-dir.get"/>
> 
> There is no match for "cocoon:/contracts-dir.get" in your xmap.
> 
> Ross
-- 
thorsten

"Together we stand, divided we fall!" 
Hey you (Pink Floyd)


Mime
View raw message