forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: xml-fop Compliance Page (was Re: xml-fop Build Failed)
Date Mon, 08 Nov 2004 00:43:44 GMT
Juan Jose Pablos wrote:
> David Crossley wrote:
> > Just to explain a little bit. There has already been
> > a lot of misunderstanding about this topic.
> > 
> > Clay already had a plain-text "catalog" file that worked
> > in his project at documentation/resources/schema/catalog
> > 
> > You have provided him with an xml-based catalog instead.
> > Either format will be okay.
> > 
> 
> I saw that, but that file did not stop these errors.

I did some further investigation and found that the
plain text catalog works fine for the 'forrest run' webapp,
but doing command-line 'forrest' it does not.

In that situation forrest is expecting a project file with
the default name of "catalog.xcat". Putting that file in my
seed project's src/documentation/resources/schema/ directory
did the trick. The validation of the compliance.xml works now.

As usual, if people want to call the file something else
e.g. "catalog.fop.xcat" then that must be declared in
the forrest.properties file.

So Clay, all you need to do is to replace your plain-text
file called "catalog" with an xml-based one called "catalog.xcat".

--David

> Only when I created 
>    the local xml-based catalog, I could validate this xml file.
> 
> I think that maybe it is on our site.
> 
> After adding this xml-based catalog, Forrest report this error:
> 
> X [0]                                     compliance.html       BROKEN: 
> /home/cheche/xml/xml-fop/src/documentation/content/xdocs/compliance-v10.dtd 
> (No such file or directory)
> 
> The only way I found to avoid this is adding the compliance public 
> identifier to forrest catalog.
> 
> 
> I need to find a way to add {project.home}/catalog.xcat to 
> catalog.forrest.xcat
> 
> WDYT?
> 
> Cheers,
> Cheche


Mime
View raw message