forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicola Ken Barozzi <nicola...@apache.org>
Subject Re: [Proposal] Java1.4 as minimum requirement
Date Mon, 04 Oct 2004 08:31:02 GMT
Clay Leeds wrote:
...
> IMO, unless there is a real, tangible reason for changing the 
> requirements, you may get more 'mileage' out of supporting an older 
> version of the JDK (i.e., more consumers of Forrest).

Ok, I understand and concur.

Unfortunately Cocoon2.2 will be using 1.4, and we are now using this 
version because of the pass-through capability that is not trivial to 
backport to the 2.1 branch.

Because of this we will continue to support 1.3 till Cocoon 2.2 does not 
actually use 1.4 stuff, and then switch to 1.4.

I guess that our policy can then be written as:

  - though shall not require the latest JDK version
  - though shall not use a newer JDK if it's not really needed

-- 
Nicola Ken Barozzi                   nicolaken@apache.org
             - verba volant, scripta manent -
    (discussions get forgotten, just code remains)
---------------------------------------------------------------------


Mime
View raw message