forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ross Gardler <rgard...@apache.org>
Subject Re: Build issues when svn switch
Date Thu, 07 Oct 2004 15:21:35 GMT
Sean Wheller wrote:
> On Thursday 07 October 2004 16:24, Ross Gardler wrote:
> 
>>Sean Wheller wrote:
>>
>>>On Thursday 07 October 2004 15:07, Ross Gardler wrote:
>>>
>>>>Sean Wheller wrote:
>>>>
>>>>>This increases the likely hood that use of the standard svn switch dev
>>>>>method will not work.
>>>>
>>>>I have been watching the commits that have been made, and most of them
>>>>are skin or docs changes. There are none of any significance with regard
>>>>to the build in the list you copied in your mail.
>>>
>>>I don't think it is the build per se. Rather that there may be bits and
>>>pieces in the update operation that cause a problem. I will try looking
>>>at it closer, but don't have time to go over all the differences, so I
>>>will test it once the branch and trunk have come closer together.
>>
>>But surely if a straight checkout of the branch works for you then it
>>can't be a problem with the code in the branch?
>>
>>What do your logs say when you get the failure?
> 
> 
> Yes, this makes sense, hence I think it has something to do with the update 
> operation. Essentially svn switch is just a super update that makes the 
> current directory mirror a new URL. There should not be any problem, 
> logically. However, the facts are the facts, both svn switch from cli and 
> eSvn have the same result. I think that somewhere the update is not being 
> done as it should due to the amount of information be transmitted and hence 
> the problem. But this is only speculation. On the other hand I may be looking 
> in the wrong place, perhaps I am just doing something wrong. Will check this 
> later.

I'm afraid I am as confused as you. As you say facts are facts and the 
branch is working for Clay and myself, yet it is not working for you. 
I'd like to be sure that it is not the code.

If you can tell me what is in your logs when you get the fail this will 
help a great deal (logs are in buils/webapp/WEB-INF/logs/ when you do a 
forrest run).

In the meantime, I'm testing the merge operation.

Ross



Mime
View raw message