forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clay Leeds <cle...@medata.com>
Subject Re: xml-fop Build Failed
Date Thu, 28 Oct 2004 15:58:08 GMT
I achieved a BUILD SUCCESSFUL running forrest-0.7-dev. Whew! You can  
check out the site here[1]. The files used to create the FOP site  
(tar.gzip'd) are here[2].

I still have a few problems I'm trying to resolve

see below...

On Oct 22, 2004, at 3:27 AM, Juan Jose Pablos wrote:
> Clay Leeds wrote:
>> I am having problems with your instructions. I'm having problems  
>> running
>> the patch file fix4fop.diff.
>
>
>> 2. cp src/documentation/content/xdocs/site.xml site.xml.bak
>
> I am not able to see this file on the CVS version. please double check  
> that you have commited.

I'm sorry about that. I first got on the job of getting the xml-fop web  
site updated ages ago (6 months?). Unfortunately, the files were in  
disarray. Soon after I started I saw that forrest was moving to 0.6, so  
I decided to make xml-fop ready for the transition to 0.6. This meant  
creating a site.xml file, removing the book.xml files, and making  
assorted other changes (skinconf.xml, forrest.properties, tabs.xml,  
etc.).

Over this long period of time, I must've forgotten that I was the one  
who created 'site.xml' on my local drive. I have since become a  
committer for xml-fop, and just committed site.xml.

>> 4. patch -p1 < fix4fop.diff
>
> I thought that you need to use p0
> patch -p0 < fix4fop.diff
>> If you couldn't already tell, I'm new to applying patches. :-)
>
> no problem, we are here to learn :-)

I never was able to get that patch to work. However, since I've been  
able to workaround the problem, I think I'm OK.

I do have a few problems I need to resolve:

CRITICAL:
- compliance.html/.xml - *no* content (should look like[5])
- design/alt.design/xml-parsing.html - *no* content (should look  
like[6])
- all links in *navigation* from  
design/alt.design/properties/introduction.html
   display *no* content (click[7] and try links in site navigation menu)

MODERATE:
- the tab corner images do not render

MINOR:
- I'd like to figure out how to transform svg=>PNG+PDF on the fly. For  
now,
   I will be generating all PNG & PDF files and placing them in their
   respective resources/* or content/* directories.
- I think the breadcrumb should display below the tabs (although that  
may be skin-related)

[1]
http://www.apache.org/~clay/xml-fop/
[2]
http://www.apache.org/~clay/xml-fop_041027.tar.gz
[3]
http://marc.theaimsgroup.com/?l=forrest-dev&m=109157457703573&w=2
[4]
http://issues.apache.org/eyebrowse/ReadMsg? 
listName=dev@forrest.apache.org&msgNo=14540
[5]
http://xml.apache.org/fop/compliance.html
[6]
http://xml.apache.org/fop/design/alt.design/xml-parsing.html
[7]
http://www.apache.org/~clay/xml-fop/design/alt.design/properties/ 
introduction.html

Web Maestro Clay
-- 
Clay Leeds - <cleeds@medata.com>
Webmaster/Developer - Medata, Inc. - <http://www.medata.com/>
PGP Public Key: <https://mail.medata.com/pgp/cleeds.asc>


Mime
View raw message