forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clay Leeds <>
Subject Re: [Proposal] Java1.4 as minimum requirement
Date Fri, 01 Oct 2004 14:55:19 GMT
On Oct 1, 2004, at 6:16 AM, Dave Brondsema wrote:
> Quoting Nicola Ken Barozzi <>:
>> Given that JDK1.5 is out, I propose that we clearly ask JRE1.4 as a
>> minimum base requirement for Forrest. This should also clear some
>> problems that users were having with IBM JDK 1.3.
>> What about also deciding that we will always ask our users to be at
>> least one point release behind the latest Java Platform?
> I use forrest regularly with jdk1.3 at work and it is fine.  The only 
> problems
> I've encountered were making sure upgraded jars were compiled with 
> jdk1.3.  I
> think it would be ok to move the requirement to 1.4 but only if we 
> have a good
> reason to abandon 1.3.  The release of Java 5.0 isn't a reason why 
> forrest
> should abandon 1.3

I concur with Dave Brondsema on this. Unless there is a significant 
reason to move away from jdk1.3 (other than just being one release 
behind the latest and greatest), you may lose potential users (and 
developers) of forrest.

I have a client running a system which cannot be upgraded to JDK 1.4 
(AIX 4.3 running IBM Java 1.3--the latest, and probably last release 
for AIX 4.3). They don't use /forrest/ in their application, but they 
do use FOP, which is also contemplating such a change with their 1.0 
release. This is unfortunate, as they won't be able to benefit from the 
improvements released in fop-1.0. The current requirement for FOP is 
'officially' JDK 1.2 (although I'm not convinced you don't actually 
need JDK 1.3).

IMO, unless there is a real, tangible reason for changing the 
requirements, you may get more 'mileage' out of supporting an older 
version of the JDK (i.e., more consumers of Forrest).

Web Maestro Clay

View raw message