forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Brondsema <d...@brondsema.net>
Subject Re: [Proposal] Java1.4 as minimum requirement
Date Fri, 01 Oct 2004 13:16:15 GMT
Quoting Nicola Ken Barozzi <nicolaken@apache.org>:

> 
> Given that JDK1.5 is out, I propose that we clearly ask JRE1.4 as a 
> minimum base requirement for Forrest. This should also clear some 
> problems that users were having with IBM JDK 1.3.
> 
> What about also deciding that we will always ask our users to be at 
> least one point release behind the latest Java Platform?
> 

I use forrest regularly with jdk1.3 at work and it is fine.  The only problems
I've encountered were making sure upgraded jars were compiled with jdk1.3.  I
think it would be ok to move the requirement to 1.4 but only if we have a good
reason to abandon 1.3.  The release of Java 5.0 isn't a reason why forrest
should abandon 1.3


-- 
Dave Brondsema : dave@brondsema.net 
http://www.brondsema.net : personal 
http://www.splike.com : programming 
http://csx.calvin.edu : student org 

Mime
View raw message