forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scherler, Thorsten" <thors...@apache.org>
Subject Re: [help] looping in pelt-dev
Date Sun, 15 Aug 2004 02:00:56 GMT
Dave Brondsema wrote:
> Scherler, Thorsten wrote:
> 
>> Hello devs, hello user,
>>
>> I am trying to track down the looping behaviour of the pelt dev skin!
>>
>> I noticed that the loop happends when
>> the following conditions are fullfield:
>> 1) the looping node is a child of a node that has the attribute e.g. 
>> href="docs/" tab="docs".
>> 2) the looping node e.g. <document-v13 label="document-v13" 
>> href="document-v13.html"/> has both attributes "label" and "href".
>>
>> Sometimes I get something like:
>> X [0] docs/docs/searching.html      BROKEN: 
>> /opt/apache/forrest/src/documentation/content/xdocs/docs/docs/searching.xml 
>> (No such file or directory)
>> That is perfect because the file does not exits.
>> ...not really because something is calling that file in that location 
>> and I do not know why! But at least is not causing an endless loop!
>>
>> but sometimes I get:
>> * [60/68]   [2/56]    2.204s 90.3Kb 
>> docs/docs/docs/docs/docs/docs/docs/docs/document-v13.dtdx.html
>> That should be BROKEN (like before) because the file does not exists 
>> in that loaction either. This is an example of a node calling an 
>> endless loop!
>>
>> I really do not know what could be causing that so please help me to 
>> track the problem! It must be something in the *.xsl.
>>
>> Please help me to find the problem! Right now I do not know what could 
>> cause that!
>>
>> Keep track when it is happening (what have the causing nodes in 
>> common). Any suggestion are welcome!
>>
>> King regards
>> thorsten
>>
> 
> 
> I've tried reverting to previous SVN revisions and have found the 
> problem back as far as when pelt-dev was css-style-dev.
>

You mean when you switch to the last revision of css-style-dev the 
looping is not happening. The next revision, where we renamed the skin, 
is starting to cause the looping. Right?

> Everything works when using a commandline override (forrest 
> -Dproject.skin=pelt-dev site) instead of the properties file.  So maybe 
> it's a bug in ForrestConfModule.java which interprets those properties.
>

Then I reckon we add a note to the pelt skin to use it like
forrest -Dproject.skin=pelt-dev site

I will have a look in the class maybe I find something!

Thanks a million Dave!

King regards
thorsten


Mime
View raw message