forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scherler, Thorsten" <thors...@apache.org>
Subject Re: Copyless for pelt-dev - Re: svn commit: rev 36266 - in forrest/trunk/src/core/context/skins/pelt-dev: . css xslt/html
Date Thu, 12 Aug 2004 22:38:02 GMT
Hi Rick,

cheers, dude!

I removed <xsl:template match="node()|@*" priority="-1"/> and it works 
fine!

Thank you very much again!

King regards
thorsten

Rick Tessner wrote:
> On Wed, 2004-08-11 at 20:06, Thorsten Scherler wrote:
> 
>>Hello Devs,
>>
>>again, why I had to copy and paste the code from common to pelt-dev to 
>>enable the external link images?
> 
> 
> Hi there,
> 
> I'd suggest removing the default template from the
> pelt-dev/xslt/html/site2html.xsl (ie the
> 
>         <xsl:template match="node()|@*" priority="-1">
> 
> template.)
> 
> This template would typically match anything not explicitly defined in
> the pelt-dev/xslt/html/site2html.xsl over anything defined in the
> imported common/xslt/html/site2html.xsl due to import precedence rules. 
> I'm not clear on how the priority attribute affects this, even after
> reading the W3C spec.  It would appear however, that the imported
> templates are not being matched since you are having to copy/paste
> templates from common into pelt-dev.
> 
> I'd try removing that template above from pelt-dev, along with any
> others that you've copy/pasted and try running forrest again. 
> Everything should work properly. :)
>   



Mime
View raw message