forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Brondsema <d...@brondsema.net>
Subject Re: latest forrest can't build incubator site
Date Mon, 23 Aug 2004 18:18:01 GMT
On Mon, 23 Aug 2004, Rodent of Unusual Size wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
>
> following ian holsman's instructions (http://tinyurl.com/5xwro),
> unfortunately i am unable to build the incubator site to add/update
> the derby.html file.  this is with the bleeding edgs forrest from
> svn.  attached is the output from a 'forrest' command run in the
> top of the checked-out incubator module.
>
> there are complaints about skins, and cocoon exceptions, and ..
> i am just a consumer of this, not a java developer, and have no
> idea how to interpret this stuff, much less get it working.
>

The skin complaint is just a warning.  Just change your forrest.properties
file to use the new skin name it suggests.

The java error seems to be something misconfigured on your system.  What
JVM and OS are you using?  Can you try it on a different system?

> i feel really uncomfortable that the incubator site is dependent
> upon what appears to be an at least somewhat fragile system.  anyone
> should be able to essentially download & go to build/update it
> without having to tweak the build tools at all.
>
> why won't the incubator site build with an actual forrest release?
> (i haven't tried it; i'm drawing this from ian's comments.)
>

Forrest 0.5.1 is pretty old so we suggest most people use the latest SVN
version.  You should be able to create sites for 0.5.1 and they'll work
find when 0.6 is released.


Mime
View raw message