forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scherler, Thorsten" <thors...@apache.org>
Subject Re: Forrest skins (repository, build errors, testing, etc.)
Date Sat, 03 Jul 2004 00:43:36 GMT
Clay Leeds wrote:

> On Jul 2, 2004, at 11:34 AM, Scherler, Thorsten wrote:
> 
>> Clay Leeds wrote:
>>
>>>> You can try the other skins but that are just some proof of 
>>>> concept   ones similar to the one from   
>>>> http://xml.apache.org/forrest/skins/skins.xml
>>>
>>> That seems like it will work! I say 'seems' because I'm still 
>>> getting   BUILD FAILED errors. I say 'seems' because it gets past 
>>> that the  SKINS  portion, but fails later. I'll paste my stack trace 
>>> (is that  what it's  called?) below...
>>
>>
>> The lenya skin should work to a certain level! It has some issue that  
>> is the reason lenya decided to drop it and work on a new version for  
>> css-style skin.
> 
> 
> Is there a reason why the skins in your /whiteboard/[1] won't work? If  
> the 'work' has been completed already...
> 

One reason would be version but you stated earlier that you are as well 
on 0.6-dev. The next one that pops in my head are three broken images. 
...but still you should at least can build the site. You will get a 
BUILD FAILED but still can see the site. I tried just now with a fresh 
seed/skin-descriptor and got three broken link.

I will *NOT* fix them because the skin in the whiteboard are *not* under 
dev anymore. Anyway just copy the missing links to the images dir and 
the skin is fixed.

So if you want try the new feature rather use the official forrest 
discriptor and try it wit a fresh /forrest seed/.

The new css-style skin will be as snapshots css-style-dev under the 
whiteboard aviable.

>>> [...]
>>>
>>> validate-sitemap:
>>> /Users/Shared/_WebDLs/cvs_stuff/xml-fop/src/documentation/ 
>>> sitemap.xmap: 126:37: error: element "pipelines" from namespace   
>>> "http://apache.org/cocoon/sitemap/1.0" not allowed in this context
>>> BUILD FAILED
>>> /Users/Shared/_WebDLs/cvs_stuff/forrest/src/core/targets/ 
>>> validate.xml: 180: Validation failed, messages should have been  
>>> provided.
>>> Total time: 29 seconds
>>
>>
>> You tried it with the fop site, or? Try it with a new seed.
>>
>> ... and fix your  
>> /Users/Shared/_WebDLs/cvs_stuff/xml-fop/src/documentation/ sitemap.xmap:
>> > 126:37: error: element "pipelines" from namespace
>> > "http://apache.org/cocoon/sitemap/1.0" not allowed in this context
> 
> 
> erm... I guess I wasn't clear... I don't know how to fix that (I guess  
> I could do some type of diff with the forrest files)... If I did, I  
> wouldn't have that error any more. :-p

LOL I thought you meant that is coming from the skin.

Reading the error message and assuming that 
/Users/Shared/_WebDLs/cvs_stuff/xml-fop/src/documentation/ is your 
project path, I thing in line 126 of your sitemap.xmap you used a 
<pipelime/> element that is offending to the 
http://apache.org/cocoon/sitemap/1.0 dtd.

Try to validate the sitemap. http://forrest.apache.org/docs/catalog.html 
if you using some of the mentioned tool of that page makes it easy to 
solve the problem if it is just a validation problem.

some reason for validation problems that I had were:
- I defined a new element in my skinconf.xml and forgot to add it to the 
  skinconfig-v06-2.dtd.
- I used two times my new element <disable-font-script/>. The error 
message were like yours. I violated above dtd with using it two times.
- I forgot to close a tag (<tag> but *no* </tag> or vice versa). The 
same error msg.
- I used special character like ä, á, ñ, ... You have to declare that as 
entity or use &#...; instead. I use eclipse and the xml-buddy let you 
format xml, so I just format my xml and all special character are 
translated.

If you can't find the error with this info just post the sitemap to the 
list ;-)
> 
>> ;-)
>>
>> King regards
>> thorsten
> 
> 
> Cheers!
> 
> Web Maestro Clay
> 
> [1]
> http://www.apache.org/~thorsten/whiteboard/forrestskins/
> 
> 


-- 
<thorsten>
  <name>Thorsten Scherler</name>
  <country>Spain</country>
  <@mail>thorsten.at.apache.org</@mail>
  <@cocoon-WIKI>
http://wiki.cocoondev.org/Wiki.jsp?page=Scherler
</@cocoon-WIKI>
  <acronymfinder>
http://www.acronymfinder.com/af-query.asp?String=exact&Find=Find&Acronym=
  </acronymfinder>
  <motto>
    "My task which I am trying to achieve is,
     by the power of the written word,
     [...] to make you see."
     *Joseph Conrad (1857-1924)*
  </motto>
</thorsten>



Mime
View raw message