forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: Using Eclipse with Forrest
Date Fri, 16 Jul 2004 01:02:25 GMT
Clay Leeds wrote:
> Scherler, Thorsten wrote:
> > I have managed to activate validation with DTD with the XMLBuddy for 
> > *single* DTD's:
> >
> > given e.g.
> > <!DOCTYPE tabs PUBLIC "-//APACHE//DTD Cocoon Documentation Tab 
> > V1.1//EN" "http://forrest.apache.org/dtd/tab-cocoon-v11.dtd">
> >
> > Goto: Preferences-XMLBuddy-XML-Validation-DTD-New
> > Root name: tabs
> > PUBLIC id: -//APACHE//DTD Cocoon Documentation Tab V1.1//EN
> > SYSTEM id: http://forrest.apache.org/dtd/tab-cocoon-v11.dtd
> 
> Thanks! It appears to work well in Eclipse 3.0!
> 
> > The only thing that kind of sucks is that you have to do it all the 
> > time for each DOCTYPE. Trying to say I have not managed to use the 
> > Catalog approach. Another drawback is that for me it is only working 
> > with SYSTEM ids that have a "http://" system id. To end up the list of 
> > drawbacks: the buddy seems to work only in 2.1.x versions of eclipse 
> > :(.
> 
> As I indicate above, it works well in Eclipse 3.0. Excellent! I've been 
> looking for a way to get this functionality to work.

Not really very excellent. Would someone consider sending a bug
report to XMLBuddy. Buddies should be friendly. Every tool should
use Catalogs.

-- 
David Crossley


Mime
View raw message