forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam R. B. Jack" <aj...@trysybase.com>
Subject Re: Build.sh and build.bat creating just JAR
Date Mon, 24 May 2004 19:42:47 GMT
> To use the new Forrest launch "build" as you already have done, and then
>   change FORREST_HOME to point to [forrest]/src/core.

Ok, so I ignored what I wrote & tried this.

> We need more testing to check that all remaining issues are ironed out
> before a release, so bug reports and suggestions are welcome :-)

We'll, I was about to say it worked for me, but although it did (manually),
it didn't work from Gump. Gump executed:

Executing:
forrest -Djava.awt.headless=true -Dproject.content-dir=. -Dproject.site-dir=
/homelocal/build/gump/local/gump-ws/forrest-staging

and received:

X [0]                                     index.html    BROKEN:
/homelocal/build
/gump/local/gump-ws/forrest-work/src/documentation/skinconf.xml (No such
file or
 directory)
Total time: 0 minutes 7 seconds,  Site size: 0 Site pages: 0

but Gump's "content" (dir above content/xdocs) is in forrest-work/ not
forrest-work/src/documentation. I found the forrest.properties file was
commented out (nothing explicitly set) but see I set it on commandline. It
seems like the commandline options is being ignored, or similar.

BTW: Whilst I am here (and for Gump running forrest) is there an exit code
difference from 'failed to build one page of your many' and 'failed to build
any pages' (due to a validation error)? Right now Gump can't tell the
difference, so sometimes gets/gives empty sites.

regards,

Adam


Mime
View raw message