forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sjur Nørstebø Moshagen <sjur.mosha...@kolumbus.fi>
Subject Re: Stuck with upgrade
Date Mon, 12 Apr 2004 21:49:46 GMT
På 12. apr. 2004 kl. 13.46 skrev Morten Damsgaard-Madsen:

> However, when I try to build my old website from version 5.1 I get the  
> following error:
...
> ----------------------------------------------------------------------- 
> -
>
> cocoon 2.1.4
>
> Copyright (c) 1999-2004 Apache Software Foundation. All rights  
> reserved.
>
> ----------------------------------------------------------------------- 
> -
>
> X [0]                                     index.html   
BROKEN:  
> java.lang.RuntimeException: java.lang.RuntimeException:  
> java.lang.RuntimeException: java.lang.RuntimeException:  
> org.xml.sax.SAXException: Attempt to output character of integral  
> value 229 that is not represented in specified output encoding of

It looks like a problem I had a while ago, the error message is the  
same. It turned out that the Xalan version used in Cocoon 2.1.4 (Xalan  
2.5.2) introduced a bug regarding handling of non-ascii characters (be  
it 8859-x or utf-8 or anything in the upper half of the 8-bit range).  
The problem vanished if I replaced version 2.5.2 with the recent 2.6.0  
(this bug did not exist in earlier versions of Xalan, and is thus not a  
problem in Forrest 0.5.1, which uses Xalan 2.5.0 IIRC). The new version  
is available at:

http://cvs.apache.org/viewcvs.cgi/cocoon-2.1/lib/endorsed/

Since this problem is actually a Cocoon-problem, and not specific to  
Forrest, I never thought of filing a bug report. But it might be a good  
thing to file one, both to inform other people of the existence of the  
bug, and as a reminder for testing against new versions of Cocoon. I'll  
try to get around filing one (haven't done that before;).

Sjur


Mime
View raw message