forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Brondsema <d...@brondsema.net>
Subject Re: upgrading an existing forrest installation
Date Tue, 30 Mar 2004 15:08:41 GMT
On Tue, 30 Mar 2004, Juan Jose Pablos wrote:

> Rob,
>
> > What is the recommended approach for upgrading an existing forrest
> > installation ?
>
> For people that use the SVN version, just remember to change your
> FORREST_HOME value.
>
> > I am in the process of using forrest for an internal documentation site and
> > having just updated my forrest build directory from SVN it now complains
> > about illegal attributes within the skinconf.xml file on the toc element.
>
> It complains about @level on the TOC element. It has been replace
> @max-depth. Now he have 2 options here:
>
> 1)allow the level attribute even it will not be used.
>
> 2) create a xsl file that convert old skin @level to be converted to
> @max-depth
>

I don't have a problem with breaking backwards compatibility here because
the fix is so easy.  We just have to make sure we document it on an
"upgrading to 0.6" page.

>
> for 2, we need to have a @version on the skinconf.
>

We need an external, versioned DTD for skinconf for many reasons.  :-)

> WDYT?
>

-- 
Dave Brondsema : dave@brondsema.net
http://www.brondsema.net : personal
http://www.splike.com : programming
http://csx.calvin.edu : student org

Mime
View raw message