forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Masover <>
Subject Re: local catalog not loaded/used, Cocoon phase of Forrest build
Date Wed, 03 Mar 2004 21:18:18 GMT
David (et al.?) --

Yes -- if I call my local catalog file catalog.xcat and leave all values commented out (default values), I can build 

Once I uncomment anything the build breaks as described in my original 
post-- whether this line only [note that I'm using "catalog.xcat" now, not 

    # A local OASIS catalog file to supplement the default Forrest catalog

or the above line plus the properties that set ${project.schema-dir}:


The lines above are copied directly from the breaking 
build -- so if something's wrong in these properties perhaps some more 
experienced person can spot the fault(s).

My immediate problem is now solved:  I can make the build work.  But 
something does still appear broken to me, as you (David) also seem to 
think.  Is this a problem I ought to submit as a bug through some mechanism 
other than postings already made to this list?

Thanks very much for your help, David.


At 02:33 AM 3/3/2004, you wrote:
>Steve Masover wrote:
> > I am using Forrest 0.5.1 on Java 1.4.2_03, and am trying to
> > add my own DTDs to a site. ...<snip/>
>I just tried the procedure and everything is fine for me.
>There were a few things that i did differently to what you
>* my "local catalog" is at
>* I just left all the defaults in as they were
>(all commented-out) except i raised the catalog verbosity to 10.
>Entries in only need to be un-commented when
>you want to vary from the defaults.
>Now, it does sound like there is something broken, because what
>you have described should work. I wonder if it is the filename
>of the "local catalog", or perhaps one of the defaults that you
>have un-commented is actually wrong in the seeded

Steve Masover

IS&T - Student Information Services
549 Banway
UC Berkeley

Steve Masover <>

View raw message